summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-06-18 17:02:33 +0200
committerPieter Goetschalckx2015-06-18 17:02:33 +0200
commit9b910cbf533e1e81abe238d6d888b6ba0ddc2f00 (patch)
tree51099c5323b1436a21f1f4c4e0d02927dab91c11
downloadaur-9b910cbf533e1e81abe238d6d888b6ba0ddc2f00.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD23
-rwxr-xr-xlicense.txt8
-rwxr-xr-xvimdoc.install19
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df915862da2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-hexman
+ pkgdesc = Simpler Hex viewing and editing
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=666
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = vim-hexman::http://www.vim.org/scripts/download_script.php?src_id=21365
+ source = license.txt
+ sha256sums = 91150d156ae1c8c33e46dbb0d0c34c87d57dec795b12f33024495002505cfaad
+ sha256sums = 1b65169352a57daa6faa024201869c9929d321157e1a6f795b664a9c56f10f9f
+
+pkgname = vim-hexman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5113d76030f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+# Contributor: Laszlo Papp <djszapi @ gmail at com>
+
+pkgname=vim-hexman
+pkgver=0.7.3
+_scriptid=21365
+pkgrel=1
+pkgdesc="Simpler Hex viewing and editing"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=666"
+license=('custom')
+depends=('vim')
+groups=('vim-plugins')
+install=vimdoc.install
+source=("${pkgname}::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}"
+ "license.txt")
+sha256sums=('91150d156ae1c8c33e46dbb0d0c34c87d57dec795b12f33024495002505cfaad'
+ '1b65169352a57daa6faa024201869c9929d321157e1a6f795b664a9c56f10f9f')
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname} ${pkgdir}/usr/share/vim/plugin/hexman.vim
+ install -Dm755 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+}
diff --git a/license.txt b/license.txt
new file mode 100755
index 000000000000..77feef729d38
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2003-2014 Peter Franz
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+hexman.vim is provided *as is* and comes with no
+warranty of any kind, either expressed or implied. In no
+event will the copyright holder be liable for any damamges
+resulting from the use of this software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*