summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-02-17 23:56:42 -0600
committerLuis Martinez2021-02-17 23:56:42 -0600
commit8c7d9657d88cfb089f848605fb39a0c2b7ac96e1 (patch)
treee636a705b06ee95a525be979cc5c5cc80229cf1b
downloadaur-8c7d9657d88cfb089f848605fb39a0c2b7ac96e1.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ae2e4ceb2cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-hexokinase-git
+ pkgdesc = (Neo)Vim plugin for asynchronously displaying hex colors
+ pkgver = r112.9f7f4ba
+ pkgrel = 1
+ url = https://github.com/RRethy/vim-hexokinase
+ arch = any
+ groups = vim-plugins
+ license = GPL
+ makedepends = git
+ depends = hexokinase
+ optdepends = neovim>=0.3.2: virtual text and sign_column support
+ optdepends = vim: sign_column support (compiled with +signs)
+ source = git+https://github.com/RRethy/vim-hexokinase
+ sha256sums = SKIP
+
+pkgname = vim-hexokinase-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..876d738f8d00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lmartinez
+pkgname=vim-hexokinase-git
+_pkgname=${pkgname%-git}
+pkgver=r112.9f7f4ba
+pkgrel=1
+pkgdesc="(Neo)Vim plugin for asynchronously displaying hex colors"
+arch=('any')
+url="https://github.com/rrethy/vim-hexokinase"
+license=('GPL')
+groups=('vim-plugins')
+depends=('hexokinase')
+optdepends=('neovim: virtual text and sign_column support'
+ 'vim: sign_column support (compiled with +signs)')
+makedepends=('git')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ find autoload doc lua plugin -type f -exec install -Dm644 '{}' \
+ "$pkgdir/usr/share/vim/vimfiles/{}" \;
+}
+