summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 20:26:25 +0000
committerAntonio Rojas2020-05-01 20:26:25 +0000
commit824ff8d81b19b028587e6a9c2eee0623b780e4cf (patch)
treea28e0c54379752fc2af03d49a0ab456af803f3e8
downloadaur-824ff8d81b19b028587e6a9c2eee0623b780e4cf.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dcb195534b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-jellybeans
+ pkgdesc = Colorful, dark color scheme, inspired by ir_black and twilight
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://github.com/nanotech/jellybeans.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim
+ source = vim-jellybeans-1.7.zip::https://github.com/nanotech/jellybeans.vim/archive/v1.7.zip
+ sha256sums = 5ef05f4ce4d72de427b69e7ced9799db77421c6b3dfa8db86dc6f40bc61d00e5
+
+pkgname = vim-jellybeans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e23d24ef2e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=vim-jellybeans
+_name=jellybeans.vim
+pkgver=1.7
+pkgrel=1
+pkgdesc='Colorful, dark color scheme, inspired by ir_black and twilight'
+arch=('any')
+url="https://github.com/nanotech/$_name"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim')
+source=("$pkgname-$pkgver.zip::https://github.com/nanotech/$_name/archive/v$pkgver.zip")
+sha256sums=('5ef05f4ce4d72de427b69e7ced9799db77421c6b3dfa8db86dc6f40bc61d00e5')
+
+prepare() {
+ head -41 "$_name-$pkgver/colors/$_name" | tail -21 | cut -b2- > LICENSE
+}
+
+package() {
+ install -Dm644 "$_name-$pkgver/colors/$_name" \
+ "$pkgdir/usr/share/vim/vimfiles/colors/$_name"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: