summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2015-07-06 20:50:29 -0400
committerJeremy Audet2015-07-06 20:50:29 -0400
commit1ca003a7a25ca00399c49442513d832a99e9fea2 (patch)
tree8c6678f94255eeda434a8277700693a08ff528f3
downloadaur-1ca003a7a25ca00399c49442513d832a99e9fea2.tar.gz
Initial commit (version v1.5.29.gf931895)
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE.txt24
-rw-r--r--PKGBUILD36
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9254360ac69b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-jellybeans-git
+ pkgdesc = A colorful, dark color scheme, inspired by ir_black and twilight.
+ pkgver = v1.5.29.gf931895
+ pkgrel = 1
+ url = https://github.com/nanotech/jellybeans.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-jellybeans
+ conflicts = vim-jellybeans
+ source = git+https://github.com/nanotech/jellybeans.vim.git
+ source = LICENSE.txt
+ sha256sums = SKIP
+ sha256sums = 914e3a036fe21cf2741e5334263ea10ec145ae894248bb95c8cb9e38f20baabf
+
+pkgname = vim-jellybeans-git
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..1aa876a0425f
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,24 @@
+Copyright (c) 2009-2012 NanoTech
+
+Permission is hereby granted, free of charge, to any per-
+son obtaining a copy of this software and associated doc-
+umentation files (the "Software"), to deal in the Soft-
+ware without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distrib-
+ute, sublicense, and/or sell copies of the Software, and
+to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
+KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO
+THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICU-
+LAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CON-
+TRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CON-
+NECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3463279f48cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jeremy 'Ichimonji10' Audet <ichimonji10 at gmail dot com>
+
+pkgname='vim-jellybeans-git'
+_repository='jellybeans.vim'
+pkgver=v1.5.29.gf931895 # see pkgver()
+pkgrel=1
+pkgdesc='A colorful, dark color scheme, inspired by ir_black and twilight.'
+arch=('any')
+url="https://github.com/nanotech/$_repository"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/nanotech/${_repository}.git" 'LICENSE.txt')
+
+sha256sums=('SKIP'
+ '914e3a036fe21cf2741e5334263ea10ec145ae894248bb95c8cb9e38f20baabf')
+
+pkgver() {
+ cd "$_repository"
+ git describe --always | sed 's/-/./g'
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 644 \
+ "$_repository/colors/jellybeans.vim" \
+ "$pkgdir/usr/share/vim/vimfiles/colors/jellybeans.vim"
+ install -Dm 644 \
+ "LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
+
+# vim:set ts=2 sw=2 et: