summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Rodas2015-06-25 00:33:38 -0500
committerMario Rodas2015-06-25 00:33:38 -0500
commit29d729f5c13fb9c89c10e438a3d60f8192a52666 (patch)
tree587d9960d45756546c23e451fe58ac80073fac90
downloadaur-29d729f5c13fb9c89c10e438a3d60f8192a52666.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2438d06b5bf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-jp-ctags
+ pkgdesc = Vim-jp fork of ctags.
+ pkgver = 0.r823.3c49059
+ pkgrel = 1
+ url = https://github.com/vim-jp/ctags
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ provides = ctags
+ conflicts = ctags
+ source = ctags::git+https://github.com/vim-jp/ctags.git
+ md5sums = SKIP
+
+pkgname = vim-jp-ctags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd2059e591c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
+
+pkgname=vim-jp-ctags
+_gitname=ctags
+pkgver=0.r823.3c49059
+pkgrel=1
+pkgdesc="Vim-jp fork of ctags."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+provides=('ctags')
+conflicts=('ctags')
+url="https://github.com/vim-jp/ctags"
+source=("$_gitname::git+https://github.com/vim-jp/ctags.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ autoheader
+ autoconf
+ ./configure --prefix=/usr --disable-external-sort
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make prefix="$pkgdir/usr" install
+}