summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-10 23:12:12 -0500
committerLuis Martinez2021-05-10 23:21:08 -0500
commitf9700f566ba04ef54ad39692ec7fcd1e3d3c668b (patch)
treea1970bbef071686200641339a5d6cbb9400ed5a9
downloadaur-f9700f566ba04ef54ad39692ec7fcd1e3d3c668b.tar.gz
initial commit based on neovim-kotlin
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909720855605
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-kotlin-git
+ pkgdesc = Vim plugin for syntax, highlighting, basic indentation, and Syntastic support
+ pkgver = r86.e043f6a
+ pkgrel = 1
+ url = https://github.com/udalov/kotlin-vim
+ arch = any
+ groups = vim-plugins
+ license = Apache
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-kotlin-git::git+https://github.com/udalov/kotlin-vim
+ sha256sums = SKIP
+
+pkgname = vim-kotlin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..459687ae7bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: thorwithpizza
+# Maintainer: relrel <relrelbachar at gmail dot com>
+# Contributor: midgard <arch dot midgard "at symbol" janmaes "youknowwhat" com>
+# Contributor: Kirill Klenov <horneds at gmail dot com>
+# Contributor: Mikhail felixoid Shiryaev <mr dot felixoid na gmail com>
+
+pkgname=vim-kotlin-git
+pkgver=r86.e043f6a
+pkgrel=1
+pkgdesc='Vim plugin for syntax, highlighting, basic indentation, and Syntastic support'
+arch=('any')
+license=('Apache')
+url='https://github.com/udalov/kotlin-vim'
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find ftdetect ftplugin indent syntax syntax_checkers \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+# vim:set ts=2 sw=2 tw=100 et: