summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsekret2015-06-09 20:06:52 +0200
committersekret2015-06-09 20:06:52 +0200
commit2ce6779ed580386adfdd566da3c12e3725bf0401 (patch)
tree66ffff25e2b8dac2680e740e5528691170d23c53
downloadaur-2ce6779ed580386adfdd566da3c12e3725bf0401.tar.gz
initial AUR4 import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--vim-latexsuite-git.install31
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f258b7093f22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vim-latexsuite-git
+ pkgdesc = Provides a comprehensive set of tools to view, edit, and compile LaTeX documents within Vim. Also provides macros to speed up the creation of LaTeX documents.
+ pkgver = 0.r817.392577f
+ pkgrel = 1
+ epoch = 1
+ url = http://vim-latex.sourceforge.net
+ install = vim-latexsuite-git.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim-runtime
+ optdepends = python2
+ optdepends = texlive-bin
+ provides = vim-latexsuite
+ conflicts = vim-latexsuite
+ source = vim-latexsuite::git+git://git.code.sf.net/p/vim-latex/vim-latex
+ md5sums = SKIP
+
+pkgname = vim-latexsuite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf385ba83bea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Contributor: Army
+_pkgname=vim-latexsuite
+pkgname=$_pkgname-git
+pkgver=0.r817.392577f
+pkgrel=1
+epoch=1
+pkgdesc="Provides a comprehensive set of tools to view, edit, and compile LaTeX documents within Vim. Also provides macros to speed up the creation of LaTeX documents."
+arch=('any')
+url="http://vim-latex.sourceforge.net"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim-runtime')
+makedepends=('git')
+optdepends=('python2' 'texlive-bin')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install=$pkgname.install
+source=("$_pkgname::git+git://git.code.sf.net/p/vim-latex/vim-latex")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ find . -type f -name *.py | xargs sed -i 's/\/usr\/bin\/python/\/usr\/bin\/env python2/g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make PREFIX="$pkgdir/usr" VIMDIR="$pkgdir/usr/share/vim/vimfiles" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vim-latexsuite-git.install b/vim-latexsuite-git.install
new file mode 100644
index 000000000000..8d6b924cc827
--- /dev/null
+++ b/vim-latexsuite-git.install
@@ -0,0 +1,31 @@
+# arg 1: the new package version
+post_install() {
+echo '%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%'
+echo '% Set the following lines in your ~/.nvimrc or the systemwide /etc/nvimrc:'
+echo '% filetype plugin indent on'
+echo '% set grepprg=grep\ -nH\ $*'
+echo '% let g:tex_flavor = "latex"'
+echo '% '
+echo '% Also, this installs to /usr/share/vim/vimfiles, which may not be in'
+echo '% your runtime path (RTP). Be sure to add it too, e.g:'
+echo '% set runtimepath=~/.nvim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.nvim/after'
+echo '%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%'
+
+# rebuild the vim documentation tags
+nvim -e -s -c 'helptags /usr/share/vim/vimfiles/doc/' -c quit
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+/bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+/bin/true
+}
+
+op=$1
+shift
+$op $*