summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-11 19:52:53 -0500
committerlmartinez-mirror2021-04-11 19:52:53 -0500
commitf327cf53a8c8f574c779931cfc3ae11d1bb3f6e1 (patch)
tree04145d2effd5b4d9ba9926cf11142be29f690a26
parentcc91bb81398cd00d4513023f0f663d0099698e43 (diff)
downloadaur-f327cf53a8c8f574c779931cfc3ae11d1bb3f6e1.tar.gz
add LICENSE and vim-plugin-runtime
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD38
3 files changed, 48 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daec940b4b84..4f7437aeaee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = vim-limelight-git
pkgdesc = Hyperfocus-writing in Vim.
pkgver = r32.4412a84
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/junegunn/limelight.vim
arch = any
license = MIT
- depends = vim
+ makedepends = git
+ depends = vim-plugin-runtime
+ optdepends = vim-goyo: Complementary Vim plugin for a zen mode-like experience
provides = vim-limelight
conflicts = vim-limelight
- source = git+https://github.com/junegunn/limelight.vim.git
+ source = vim-limelight-git::git+https://github.com/junegunn/limelight.vim
+ source = LICENSE
sha256sums = SKIP
+ sha256sums = 595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f
pkgname = vim-limelight-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c28e01df1b6c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2015 Junegunn Choi
+
+MIT License
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index fc552319465a..a2bb8253e22b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# vim-limelight
-
-# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
-
+# Maintainer: lmartinez-mirror
+# Contributor: Andrea Feletto <andrea@andreafeletto.com>
pkgname=vim-limelight-git
-_pkgname=limelight.vim
pkgver=r32.4412a84
-pkgrel=1
+pkgrel=2
pkgdesc='Hyperfocus-writing in Vim.'
arch=('any')
url='https://github.com/junegunn/limelight.vim'
license=('MIT')
-depends=('vim')
-conflicts=('vim-limelight')
-provides=('vim-limelight')
-source=("git+https://github.com/junegunn/$_pkgname.git")
-sha256sums=('SKIP')
+depends=('vim-plugin-runtime')
+optdepends=('vim-goyo: Complementary Vim plugin for a zen mode-like experience')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url"
+ 'LICENSE')
+sha256sums=('SKIP'
+ '595e5c7670f76137827109954edd66d57ff85ce6f79a7548ea5dd588a4e22f7f')
pkgver() {
- cd "$srcdir/$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- vimfiles="$pkgdir/usr/share/vim/vimfiles"
-
- cd "$srcdir/$_pkgname"
- install -dv "$vimfiles"
- cp -R autoload plugin test "$vimfiles/"
+ cd "$pkgname"
+ find autoload plugin \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
-