summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2016-01-21 11:27:47 +0100
committerCedric Girard2016-01-21 11:27:47 +0100
commit15a6a8e56f10a0040f2ca546ff3af263fddb5d23 (patch)
tree3d0b413818e819a3a892ce6b6c066497827ed5bc
downloadaur-15a6a8e56f10a0040f2ca546ff3af263fddb5d23.tar.gz
first package version from AUR3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f40886bd213
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 10:27:37 UTC 2016
+pkgbase = vim-live-latex-preview
+ pkgdesc = Vim plugin and helper scripts to provide a live-updating PDF preview of LaTeX documents with MuPDF
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://bbs.archlinux.org/viewtopic.php?id=107164
+ arch = any
+ license = GPL
+ depends = texlive-core
+ depends = vim
+ depends = xdotool
+ depends = mupdf
+ source = http://people.umass.edu/umass298y-klement/vim-live-latex-preview-0.9.tar.gz
+ md5sums = 3a1d506673ba6c5556d502c0c9d4cdb3
+
+pkgname = vim-live-latex-preview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f64825db8d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: frabjous <klement at philos dot umass edu>
+pkgname=vim-live-latex-preview
+pkgver=0.9
+pkgrel=1
+pkgdesc="Vim plugin and helper scripts to provide a live-updating PDF preview of LaTeX documents with MuPDF"
+arch=('any')
+url="https://bbs.archlinux.org/viewtopic.php?id=107164"
+license=('GPL')
+depends=('texlive-core' 'vim' 'xdotool' 'mupdf')
+source=(http://people.umass.edu/umass298y-klement/${pkgname}-${pkgver}.tar.gz)
+md5sums=('3a1d506673ba6c5556d502c0c9d4cdb3')
+
+package() {
+ cd "${srcdir}"
+ install -d "${pkgdir}"/usr/share/vim/vimfiles/ftplugin/tex/
+ install -m 644 *.vim "${pkgdir}"/usr/share/vim/vimfiles/ftplugin/tex/
+ install -m 644 *.txt "${pkgdir}"/usr/share/vim/vimfiles/ftplugin/tex/
+ install -d "${pkgdir}"/usr/bin/
+ install -D -m 755 *.sh "${pkgdir}"/usr/bin/
+}
+
+# vim:set ts=2 sw=2 et: