summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2015-10-06 17:54:02 +0200
committerCedric Girard2015-10-06 17:54:02 +0200
commit8c693aad7c3c7e10f8a14c1c4b33f5fa4ea0596d (patch)
tree1ef3f299d740967f5d2b4ce5365b8aff7cf506e3
downloadaur-8c693aad7c3c7e10f8a14c1c4b33f5fa4ea0596d.tar.gz
first package version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac084092e74e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Oct 6 15:53:50 UTC 2015
+pkgbase = vim-logstash-git
+ pkgdesc = Vim highlights configuration files for logstash
+ pkgver = r11.6d96810
+ pkgrel = 1
+ url = https://github.com/robbles/logstash.vim
+ arch = any
+ license = MIT
+ depends = vim
+ source = vim-logstash::git+https://github.com/robbles/logstash.vim.git
+ sha256sums = SKIP
+
+pkgname = vim-logstash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7175f2282e5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+
+pkgname=vim-logstash-git
+pkgver=r11.6d96810
+pkgrel=1
+pkgdesc='Vim highlights configuration files for logstash'
+arch=('any')
+url='https://github.com/robbles/logstash.vim'
+license=('MIT')
+depends=('vim')
+source=("vim-logstash::git+https://github.com/robbles/logstash.vim.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/vim-logstash
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$srcdir"/vim-logstash
+ local installpath="$pkgdir/usr/share/vim/vimfiles"
+ install -Dm644 ftdetect/logstash.vim "$installpath/ftdetect/logstash.vim"
+ install -Dm644 syntax/logstash.vim "$installpath/syntax/logstash.vim"
+}
+
+# vim:set ts=2 sw=2 et: