summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-27 00:30:31 -0500
committerVincent Grande2020-12-27 00:30:31 -0500
commit9416b5368363479c8fc976566831ba71b0548eb8 (patch)
tree0f1b889bf00462ec7444cb563720cd4b3fd3be1a
downloadaur-9416b5368363479c8fc976566831ba71b0548eb8.tar.gz
initial upload
-rw-r--r--.SRCINFO63
-rw-r--r--PKGBUILD164
-rw-r--r--archlinux.vim46
-rw-r--r--vimdoc.hook11
-rw-r--r--vimrc18
5 files changed, 302 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0caea0689c59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,63 @@
+pkgbase = vim-min
+ pkgdesc = Vi Improved, a highly configurable, improved version of the vi text editor
+ pkgver = 8.2.1989
+ pkgrel = 1
+ url = https://www.vim.org
+ arch = x86_64
+ license = custom:vim
+ makedepends = glibc
+ makedepends = libgcrypt
+ makedepends = python
+ makedepends = libxt
+ makedepends = gawk
+ makedepends = tcl
+ makedepends = pcre
+ makedepends = zlib
+ makedepends = libffi
+ source = https://github.com/vim/vim/archive/v8.2.1989/-8.2.1989.tar.gz
+ source = vimrc
+ source = archlinux.vim
+ source = vimdoc.hook
+ sha256sums = 81d5d6a48cd421c7a8056f9436436de1ed37598341cbec3b1db7ff99c3889276
+ sha256sums = b16e85e457397ab2043a7ee0a3c84307c6b4eac157fd0b721694761f25b3ed5b
+ sha256sums = cc3d931129854c298eb22e993ec14c2ad86cc1e70a08a64496f5e06559289972
+ sha256sums = 8e9656934d9d7793063230d15a689e10455e6db9b9fe73afa0f294792795d8ae
+ sha512sums = 5d13be4220111a94d8b6b82b6516d4a51a86d4ff85890df2eb0c559e6adb7ace6aa8217f5893013961eeaedfd494cd1c04bbb4c1db3c9356425961e5890e06d7
+ sha512sums = 4b5bed0813f22af9e158ea9aa56a4a9862dd786ba2d201f20159ccf652da6190164aaed0b6b7217d578f7b25c33a8adcc307bfcf3caa8d173a7ff29e2a00fee7
+ sha512sums = fe091d289d876f45319c898f6021ef86d6a238b540c225a279c46efc5c36fa7d868cd0cee73a111811c4be90df160f85340bb251be3a437727dbe5c699950363
+ sha512sums = a02ad0d66f300160911aeb81d8886c6c558436ac4ee3fcd161dd65c6b1e5d1f41b9005a7f5bb5ba68d57027fc1c8e43daabf055bd6207fb5a216a67f758df8d1
+
+pkgname = vim-min
+ depends = vim-runtime
+ depends = acl
+ depends = glibc
+ depends = libgcrypt
+ depends = pcre
+ depends = zlib
+ depends = libffi
+ optdepends = python2: Python 2 language support
+ optdepends = python: Python 3 language support
+ optdepends = ruby: Ruby language support
+ optdepends = lua: Lua language support
+ optdepends = perl: Perl language support
+ optdepends = tcl: Tcl language support
+ provides = xxd
+ provides = vim
+ provides = vim-minimal
+ provides = vim-python3
+ provides = vim-plugin-runtime
+ conflicts = gvim
+ conflicts = vim
+ conflicts = vim-minimal
+ conflicts = vim-python3
+ replaces = vim-python3
+
+pkgname = vim-runtime-min
+ pkgdesc = Vi Improved, a highly configurable, improved version of the vi text editor (shared runtime)
+ optdepends = sh: support for some tools and macros
+ optdepends = python: demoserver example tool
+ optdepends = gawk: mve tools upport
+ provides = vim-runtime
+ conflicts = vim-runtime
+ backup = etc/vimrc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cf0b1471862
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,164 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Thomas Dziedzic <gostrc@gmail.com>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: tobias [ tobias at archlinux org ]
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+
+pkgname=('vim-min' 'vim-runtime-min')
+pkgver=8.2.1989
+_versiondir=82
+pkgrel=1
+pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
+url='https://www.vim.org'
+arch=('x86_64')
+license=('custom:vim')
+makedepends=('glibc' 'libgcrypt' 'python' 'libxt'
+ 'gawk' 'tcl' 'pcre' 'zlib' 'libffi')
+source=(https://github.com/vim/vim/archive/v${pkgver}/${pkgbase}-${pkgver}.tar.gz
+ vimrc
+ archlinux.vim
+ vimdoc.hook)
+sha256sums=('81d5d6a48cd421c7a8056f9436436de1ed37598341cbec3b1db7ff99c3889276'
+ 'b16e85e457397ab2043a7ee0a3c84307c6b4eac157fd0b721694761f25b3ed5b'
+ 'cc3d931129854c298eb22e993ec14c2ad86cc1e70a08a64496f5e06559289972'
+ '8e9656934d9d7793063230d15a689e10455e6db9b9fe73afa0f294792795d8ae')
+sha512sums=('5d13be4220111a94d8b6b82b6516d4a51a86d4ff85890df2eb0c559e6adb7ace6aa8217f5893013961eeaedfd494cd1c04bbb4c1db3c9356425961e5890e06d7'
+ '4b5bed0813f22af9e158ea9aa56a4a9862dd786ba2d201f20159ccf652da6190164aaed0b6b7217d578f7b25c33a8adcc307bfcf3caa8d173a7ff29e2a00fee7'
+ 'fe091d289d876f45319c898f6021ef86d6a238b540c225a279c46efc5c36fa7d868cd0cee73a111811c4be90df160f85340bb251be3a437727dbe5c699950363'
+ 'a02ad0d66f300160911aeb81d8886c6c558436ac4ee3fcd161dd65c6b1e5d1f41b9005a7f5bb5ba68d57027fc1c8e43daabf055bd6207fb5a216a67f758df8d1')
+
+prepare() {
+ (cd vim-${pkgver}/src
+ # define the place for the global (g)vimrc file (set to /etc/vimrc)
+ sed -E 's|^.*(#define SYS_.*VIMRC_FILE.*").*$|\1|g' -i feature.h
+ sed -E 's|^.*(#define VIMRC_FILE.*").*$|\1|g' -i feature.h
+ autoconf
+ )
+ cp -a vim-${pkgver} gvim-${pkgver}
+}
+
+build() {
+ cd vim-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var/lib/vim \
+ --with-features=normal \
+ --with-compiledby='Arch Linux' \
+ --disable-gpm \
+ --enable-acl \
+ --with-x=no \
+ --disable-gui \
+ --enable-multibyte \
+ --enable-cscope \
+ --disable-netbeans \
+ --enable-perlinterp=dynamic \
+ --enable-pythoninterp=dynamic \
+ --enable-python3interp=dynamic \
+ --enable-rubyinterp=dynamic \
+ --enable-luainterp=dynamic \
+ --enable-tclinterp=dynamic \
+ --disable-canberra \
+ --disable-darwin \
+ --disable-smack \
+ --disable-selinux \
+ --disable-luainterp \
+ --without-luajit \
+ --disable-arabic \
+ --disable-farsi \
+ --disable-gtk2-check \
+ --disable-gnome-check \
+ --disable-gtk3-check \
+ --disable-motif-check \
+ --disable-athena-check \
+ --disable-gtktest \
+ --disable-sysmouse \
+ make
+}
+#check() {
+# cd vim-${pkgver}
+# TERM=xterm make -j1 test
+#}
+
+package_vim-runtime-min() {
+ pkgdesc+=' (shared runtime)'
+ optdepends=('sh: support for some tools and macros'
+ 'python: demoserver example tool'
+ 'gawk: mve tools upport')
+ provides=(vim-runtime)
+ conflicts=(vim-runtime)
+ backup=('etc/vimrc')
+
+ cd vim-${pkgver}
+
+ make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+ # man and bin files belong to 'vim'
+ rm -r "${pkgdir}"/usr/share/man/ "${pkgdir}"/usr/bin/
+
+ # Don't forget logtalk.dict
+ install -Dm 644 runtime/ftplugin/logtalk.dict \
+ "${pkgdir}"/usr/share/vim/vim${_versiondir}/ftplugin/logtalk.dict
+
+ # rc files
+ install -Dm 644 "${srcdir}"/vimrc "${pkgdir}"/etc/vimrc
+ install -Dm 644 "${srcdir}"/archlinux.vim \
+ "${pkgdir}"/usr/share/vim/vimfiles/archlinux.vim
+
+ # rgb.txt file
+ install -Dm 644 runtime/rgb.txt \
+ "${pkgdir}"/usr/share/vim/vim${_versiondir}/rgb.txt
+
+ # no desktop files and icons
+ rm -r "${pkgdir}"/usr/share/{applications,icons}
+
+ # license
+ install -dm 755 "${pkgdir}"/usr/share/licenses/vim-runtime
+ ln -s /usr/share/vim/vim${_versiondir}/doc/uganda.txt \
+ "${pkgdir}"/usr/share/licenses/vim-runtime/license.txt
+
+ # pacman hook for documentation helptags
+ install -Dm 644 "${srcdir}"/vimdoc.hook "${pkgdir}"/usr/share/libalpm/hooks/vimdoc.hook
+}
+
+package_vim-min() {
+ depends=("vim-runtime" 'acl' 'glibc' 'libgcrypt' 'pcre'
+ 'zlib' 'libffi')
+ optdepends=('python2: Python 2 language support'
+ 'python: Python 3 language support'
+ 'ruby: Ruby language support'
+ 'lua: Lua language support'
+ 'perl: Perl language support'
+ 'tcl: Tcl language support')
+ conflicts=('gvim' 'vim' 'vim-minimal' 'vim-python3')
+ provides=('xxd' 'vim' 'vim-minimal' 'vim-python3' 'vim-plugin-runtime')
+ replaces=('vim-python3')
+
+ cd vim-${pkgver}
+ make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+ # provided by (n)vi in core
+ rm "${pkgdir}"/usr/bin/{ex,view}
+
+ # delete some manpages
+ find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ while read _mandir; do
+ cd "${_mandir}"
+ rm -f ex.1 view.1 # provided by (n)vi
+ rm -f evim.1 # this does not make sense if we have no GUI
+ done
+
+ # Runtime provided by runtime package
+ rm -r "${pkgdir}"/usr/share/vim
+
+ # remove gvim.desktop as not included
+ rm "${pkgdir}"/usr/share/applications/gvim.desktop
+
+ # license
+ install -Dm 644 runtime/doc/uganda.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/archlinux.vim b/archlinux.vim
new file mode 100644
index 000000000000..2b71ccbe275d
--- /dev/null
+++ b/archlinux.vim
@@ -0,0 +1,46 @@
+" The Arch Linux global vimrc - setting only a few sane defaults
+"
+" DO NOT EDIT THIS FILE. IT'S OVERWRITTEN UPON UPGRADES.
+"
+" Use /etc/vimrc for system-wide and $HOME/.vimrc for personal configuration
+" (for details see ':help initialization').
+"
+" Use :help '<option>' to see the documentation for the given option.
+
+" Use Vim defaults instead of 100% vi compatibility
+" Avoid side-effects when nocompatible has already been set.
+if &compatible
+ set nocompatible
+endif
+
+set backspace=indent,eol,start
+set ruler
+set suffixes+=.aux,.bbl,.blg,.brf,.cb,.dvi,.idx,.ilg,.ind,.inx,.jpg,.log,.out,.png,.toc
+set suffixes-=.h
+set suffixes-=.obj
+
+" Move temporary files to a secure location to protect against CVE-2017-1000382
+if exists('$XDG_CACHE_HOME')
+ let &g:directory=$XDG_CACHE_HOME
+else
+ let &g:directory=$HOME . '/.cache'
+endif
+let &g:undodir=&g:directory . '/vim/undo//'
+let &g:backupdir=&g:directory . '/vim/backup//'
+let &g:directory.='/vim/swap//'
+" Create directories if they doesn't exist
+if ! isdirectory(expand(&g:directory))
+ silent! call mkdir(expand(&g:directory), 'p', 0700)
+endif
+if ! isdirectory(expand(&g:backupdir))
+ silent! call mkdir(expand(&g:backupdir), 'p', 0700)
+endif
+if ! isdirectory(expand(&g:undodir))
+ silent! call mkdir(expand(&g:undodir), 'p', 0700)
+endif
+
+" Make shift-insert work like in Xterm
+if has('gui_running')
+ map <S-Insert> <MiddleMouse>
+ map! <S-Insert> <MiddleMouse>
+endif
diff --git a/vimdoc.hook b/vimdoc.hook
new file mode 100644
index 000000000000..07af3cc50234
--- /dev/null
+++ b/vimdoc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/vim/vimfiles/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q"
+When = PostTransaction
diff --git a/vimrc b/vimrc
new file mode 100644
index 000000000000..ee36a5269244
--- /dev/null
+++ b/vimrc
@@ -0,0 +1,18 @@
+" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
+" you can find below. If you wish to change any of those settings, you should
+" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
+" everytime an upgrade of the vim packages is performed. It is recommended to
+" make changes after sourcing archlinux.vim since it alters the value of the
+" 'compatible' option.
+
+" This line should not be removed as it ensures that various options are
+" properly set to work with the Vim-related packages.
+runtime! archlinux.vim
+
+" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
+" Or better yet, read /usr/share/vim/vim80/vimrc_example.vim or the vim manual
+" and configure vim to your own liking!
+
+" do not load defaults if ~/.vimrc is missing
+"let skip_defaults_vim=1