summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2015-08-14 14:55:23 +0200
committerPeter Mattern2015-08-14 14:55:23 +0200
commited7944b3df27b3e1c21ac4acb060535d7f5be8f5 (patch)
tree4df492c2e677f244ddbb56d09d44ece32dbb50c3
downloadaur-ed7944b3df27b3e1c21ac4acb060535d7f5be8f5.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD73
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e4241d68707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vim-minimal-git
+ pkgdesc = Vim the editor. CLI version providing small subset of available features.
+ pkgver = 7.4.824
+ pkgrel = 1
+ url = http://www.vim.org
+ arch = i686
+ arch = x86_64
+ license = custom:vim
+ makedepends = git
+ depends = vim-runtime-git
+ provides = vim-minimal
+ provides = xxd
+ conflicts = vim-git
+ conflicts = gvim-git
+ conflicts = vim-minimal
+ conflicts = vim
+ conflicts = vim-python3
+ conflicts = gvim
+ conflicts = gvim-python3
+ source = git+https://github.com/vim/vim.git
+ sha256sums = SKIP
+
+pkgname = vim-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8269dbe2e4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=vim
+pkgname="$_pkgname-minimal-git"
+pkgver=7.4.824
+pkgrel=1
+pkgdesc="Vim the editor. CLI version providing small subset of available features."
+arch=("i686" "x86_64")
+url="http://www.vim.org"
+license=("custom:vim")
+depends=("vim-runtime-git")
+makedepends=("git")
+provides=("vim-minimal" "xxd")
+conflicts=("vim-git" "gvim-git"
+ "vim-minimal" "vim" "vim-python3" "gvim" "gvim-python3")
+source=("git+https://github.com/vim/vim.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+prepare() {
+
+ # set global configuration file to /etc/vimrc
+ sed -i 's|^.*\(#define SYS_VIMRC_FILE.*"\) .*$|\1|' $_pkgname/src/feature.h
+
+}
+
+build() {
+
+ cd $_pkgname
+ ./configure \
+ --enable-fail-if-missing \
+ --with-compiledby='Arch Linux AUR' \
+ --prefix=/usr \
+ --enable-gui=no \
+ --with-features=tiny \
+ --enable-perlinterp=no \
+ --enable-pythoninterp=no \
+ --enable-python3interp=no \
+ --enable-rubyinterp=no \
+ --enable-luainterp=no
+ make
+
+}
+
+package() {
+
+ # actual installation
+ cd $_pkgname
+ make DESTDIR=$pkgdir install
+
+ # remove ex/view and man pages (normally provided by package 'vi' on Arch Linux) as
+ # well as man evim (not needed in a package providing CLI tools only)
+ cd $pkgdir/usr/bin ; rm ex view
+ find $pkgdir/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ while read _mandir; do
+ cd ${_mandir}
+ rm -f ex.1 view.1
+ rm -f evim.1
+ done
+
+ # remove components provided by vim-runtime-git
+ cd $pkgdir
+ rm -R usr/share/vim
+
+ # add license
+ install -D -m644 $srcdir/$_pkgname/runtime/doc/uganda.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+}