summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-29 06:23:23 +0200
committeraksr2015-06-29 06:23:23 +0200
commitf01256f234187c6c131501d195330124535964b5 (patch)
treedfbc554d48dd67f638f0f5ad1b00381d5e35de12
downloadaur-f01256f234187c6c131501d195330124535964b5.tar.gz
Start.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--vim-molokai-git.install14
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe2d5fc35e6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-molokai-git
+ pkgdesc = Port of the TextMate's monokai colorscheme for Vim.
+ pkgver = r43.db8ce13
+ pkgrel = 1
+ url = https://github.com/tomasr/molokai
+ install = vim-molokai-git.install
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = git
+ depends = vim
+ provides = vim-molokai
+ source = vim-molokai-git::git+https://github.com/tomasr/molokai.git
+ md5sums = SKIP
+
+pkgname = vim-molokai-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e6ab0eb005
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=vim-molokai-git
+pkgver=r43.db8ce13
+pkgrel=1
+epoch=
+pkgdesc="Port of the TextMate's monokai colorscheme for Vim."
+arch=('any')
+url="https://github.com/tomasr/molokai"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('vim-molokai')
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=vim-molokai-git.install
+source=("$pkgname::git+https://github.com/tomasr/molokai.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname/colors"
+ install -Dm644 molokai.vim $pkgdir/usr/share/vim/vimfiles/colors/molokai.vim
+}
+
diff --git a/vim-molokai-git.install b/vim-molokai-git.install
new file mode 100644
index 000000000000..fe63be3d59af
--- /dev/null
+++ b/vim-molokai-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo ">>> By default, it has a dark gray background based on the version created by Hamish Stuart Macpherson for the E editor."
+ echo " 256-Color terminals are also supported, though there are some differences with the Gui version."
+ echo " Only the dark gray background style is supported on terminal vim at this time."
+ echo " If you prefer the scheme to match the original monokai background color, put this in your .vimrc file: "
+ echo " let g:molokai_original = 1"
+ echo ""
+ echo ">>> There is also an alternative scheme under development for color terminals which attempts to bring the 256 color version "
+ echo " as close as possible to the the default (dark) GUI version."
+ echo " To access, add this to your .vimrc:"
+ echo " let g:rehash256 = 1"
+ /bin/true
+}
+