summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2015-07-05 15:56:43 -0500
committerAlfredo Ramos2015-07-05 15:56:43 -0500
commit95ecc86a35069741f397b4d998c3ae14120ed65a (patch)
tree482c29d1ce6b569e86a3fb661fd1cc8256b3266b
downloadaur-95ecc86a35069741f397b4d998c3ae14120ed65a.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rw-r--r--vim-monokai-git.install22
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cfb3c71afed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-monokai-git
+ pkgdesc = A port of the Monokai color scheme for Vim. Color scheme by sickill.
+ pkgver = r18.148c0d5
+ pkgrel = 1
+ url = https://github.com/sickill/vim-monokai
+ install = vim-monokai-git.install
+ arch = any
+ license = unknown
+ makedepends = git
+ optdepends = vim-python3: for vim with Python 3 interpreter support
+ provides = vim-monokai=r18.148c0d5
+ source = git+https://github.com/sickill/vim-monokai.git
+ source = vim-monokai-git.install
+ sha512sums = SKIP
+ sha512sums = e83b44527f9c45a81f6faed689462fdabac55d9f7ce6f3bdb08e00a344baa16d99adf0c39d278488d59595c577093d0404aacfa98563a2ee1db821d5dab3632b
+
+pkgname = vim-monokai-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..def6008ede4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alfredo Ramos <alfredo dot ramos at yandex dot com>s
+
+_pkgname=vim-monokai
+pkgname=${_pkgname}-git
+pkgver=r18.148c0d5
+pkgrel=1
+pkgdesc='A port of the Monokai color scheme for Vim. Color scheme by sickill.'
+arch=('any')
+url='https://github.com/sickill/vim-monokai'
+license=('unknown')
+
+optdepends=(
+ 'vim-python3: for vim with Python 3 interpreter support'
+)
+makedepends=('git')
+provides=("${_pkgname}=${pkgver}")
+
+install=${pkgname}.install
+
+source=(
+ "git+https://github.com/sickill/${_pkgname}.git"
+ "${pkgname}.install"
+)
+sha512sums=(
+ 'SKIP'
+ 'e83b44527f9c45a81f6faed689462fdabac55d9f7ce6f3bdb08e00a344baa16d99adf0c39d278488d59595c577093d0404aacfa98563a2ee1db821d5dab3632b'
+)
+
+pkgver() {
+ # Updating package version
+ cd ${srcdir}/${_pkgname}
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ # Installing package
+ cd ${srcdir}/${_pkgname}
+ mkdir -p ${pkgdir}/usr/share/vim/vimfiles
+ cp -R ./colors ${pkgdir}/usr/share/vim/vimfiles
+} \ No newline at end of file
diff --git a/vim-monokai-git.install b/vim-monokai-git.install
new file mode 100644
index 000000000000..92519ed7c7ae
--- /dev/null
+++ b/vim-monokai-git.install
@@ -0,0 +1,22 @@
+color_reset="\e[0m"
+bold_green="${color_reset}\e[1;32m"
+bold_blue="${color_reset}\e[1;34m"
+bold_white="${color_reset}\e[1;37m"
+bold_underline_white="${color_reset}\e[4;1;37m"
+bold_yellow="${color_reset}\e[1;33m"
+
+post_install() {
+ echo -e "${bold_green}==>${color_reset} ${bold_white}Edit your vimrc file${color_reset}"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}Add ${bold_underline_white}monokai${bold_white} as your current color scheme. Example:${color_reset}"
+ echo -e "\n${bold_white}colorscheme${color_reset} ${bold_underline_white}monokai${color_reset}"
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ echo -e "${bold_green}==>${color_reset} ${bold_white}Edit your vimrc file${color_reset}"
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}Remove the following line:${color_reset}"
+ echo -e "\n${bold_white}colorscheme${color_reset} ${bold_underline_white}monokai${color_reset}"
+} \ No newline at end of file