summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetervaro2016-12-11 23:09:03 +0000
committerpetervaro2016-12-11 23:09:03 +0000
commit9f41232823d9f9c4f4faae1182e5cba350ed06c4 (patch)
tree9e91e48b466fb9cc6af7e9b73455b70ac4efa9c9
downloadaur-9f41232823d9f9c4f4faae1182e5cba350ed06c4.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--vimdoc.install15
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..064fadc04728
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-multiple-cursors-git
+ pkgdesc = True Sublime Text style multiple selections for Vim
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/terryma/vim-multiple-cursors
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ source = git://github.com/terryma/vim-multiple-cursors.git
+ md5sums = SKIP
+
+pkgname = vim-multiple-cursors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25029132e01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Peter Varo <hello@petervaro.com>
+
+pkgname=vim-multiple-cursors-git
+pkgver=latest
+pkgrel=1
+pkgdesc="True Sublime Text style multiple selections for Vim"
+arch=('any')
+url="https://github.com/terryma/vim-multiple-cursors"
+license=('MIT')
+groups=('vim-plugins')
+makedepends=('git')
+install='vimdoc.install'
+source=("git://github.com/terryma/vim-multiple-cursors.git")
+md5sums=('SKIP')
+
+package() {
+ cd "vim-multiple-cursors"
+ _installpath="$pkgdir/usr/share/vim/vimfiles"
+ install -Dm755 doc/multiple_cursors.txt "$_installpath/doc/multiple_cursors.txt"
+ install -Dm755 plugin/multiple_cursors.vim "$_installpath/plugin/multiple_cursors.vim"
+ install -Dm755 autoload/multiple_cursors.vim "$_installpath/autoload/multiple_cursors.vim"
+ install -Dm644 MIT-LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..125fa2be15b6
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+