summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-25 13:04:31 -0500
committerLuis Martinez2021-04-25 13:04:31 -0500
commit64a42417434c47c04f2329ff40f980ff39257b6f (patch)
tree2fcb6f44737b27fc53926a765466a9c318698f5c
parent93e027d4c4932f19c96ef1252aaf3a82e6478342 (diff)
downloadaur-64a42417434c47c04f2329ff40f980ff39257b6f.tar.gz
rewrite to split package
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD59
3 files changed, 60 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ef316d53016..ab81e61aefb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,29 @@
pkgbase = vim-nord-git
- pkgdesc = A arctic, north-bluish clean and elegant Vim theme.
- pkgver = r51.05d536f
+ pkgdesc = An arctic, north-bluish clean and elegant Vim theme.
+ pkgver = 0.7.0.r94.gea7ff9c
pkgrel = 1
url = https://github.com/arcticicestudio/nord-vim
arch = any
groups = vim-plugins
- license = Apache
+ license = MIT
makedepends = git
- depends = vim
- source = vim-nord-git::git+https://github.com/arcticicestudio/nord-vim.git
+ source = vim-nord-git::git+https://github.com/arcticicestudio/nord-vim
md5sums = SKIP
pkgname = vim-nord-git
+ depends = vim-plugin-runtime
+ provides = vim-nord
+ conflicts = vim-nord
+
+pkgname = vim-airline-nord-git
+ depends = vim-airline
+ depends = vim-plugin-runtime
+ provides = vim-airline-nord
+ conflicts = vim-airline-nord
+
+pkgname = vim-lightline-nord-git
+ depends = vim-lightline
+ depends = vim-plugin-runtime
+ provides = vim-lightline-nord
+ conflicts = vim-lightline-nord
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
index d80235edd259..abd0aecf182d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,49 @@
-# Maintainer: reedts <j.reedts at gmail dot com>
-pkgname=vim-nord-git
-pkgver=r51.05d536f
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: reedts <j.reedts at gmail dot com>
+pkgbase=vim-nord-git
+pkgname=('vim-nord-git' 'vim-airline-nord-git' 'vim-lightline-nord-git')
+pkgver=0.7.0.r94.gea7ff9c
pkgrel=1
-epoch=
-pkgdesc="A arctic, north-bluish clean and elegant Vim theme."
+pkgdesc="An arctic, north-bluish clean and elegant Vim theme."
arch=('any')
url="https://github.com/arcticicestudio/nord-vim"
-license=('Apache')
+license=('MIT')
groups=('vim-plugins')
-depends=('vim')
makedepends=('git')
-optdepends=()
-checkdepends=()
-conflicts=()
-provides=('vim-nord-git')
-replaces=()
-backup=()
-options=()
-changelog=
-source=("$pkgname::git+https://github.com/arcticicestudio/nord-vim.git")
-noextract=()
+source=("$pkgbase::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgbase"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
-package() {
- cd "$srcdir/$pkgname"
- install -Dm644 colors/nord.vim $pkgdir/usr/share/vim/vimfiles/colors/nord.vim
+package_vim-nord-git() {
+ depends=('vim-plugin-runtime')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dm644 colors/nord.vim -t "$pkgdir/usr/share/vim/vimfiles/colors/"
+ install -Dm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+
+package_vim-airline-nord-git() {
+ depends=('vim-airline' 'vim-plugin-runtime')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dm 644 autoload/airline/themes/nord.vim -t "$pkgdir/usr/share/vim/vimfiles/autoload/airline/themes/"
+ install -Dm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
}
+package_vim-lightline-nord-git() {
+ depends=('vim-lightline' 'vim-plugin-runtime')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase"
+ install -Dm 644 autoload/lightline/colorscheme/nord.vim -t "$pkgdir/usr/share/vim/vimfiles/autoload/lightline/colorscheme/"
+ install -Dm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname/"
+}