summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPyromaniac2015-07-24 13:26:23 +0200
committerPyromaniac2015-07-24 13:26:23 +0200
commitf0ae0033498b9eabccb83b8db3477c4ab2931346 (patch)
tree02ddf5d43843e5ecd566a56bb323bd0d098ace00
downloadaur-f0ae0033498b9eabccb83b8db3477c4ab2931346.tar.gz
Initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD59
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf3b9f33fadd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-nox
+ pkgdesc = Vi Improved, console-only build with python2 support.
+ pkgver = 7.4.796
+ pkgrel = 1
+ url = http://www.vim.org
+ arch = i686
+ arch = x86_64
+ license = custom:vim
+ makedepends = python2
+ depends = gpm
+ provides = vim
+ conflicts = vim
+ conflicts = vim-runtime
+ source = https://vim.googlecode.com/archive/v7-4-796.tar.gz
+ md5sums = SKIP
+
+pkgname = vim-nox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..098f3c8e030e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Mikhail Burakov <mikhail.burakov gmail com>
+
+pkgname=vim-nox
+pkgver=7.4.796
+repover=v${pkgver//./-}
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('custom:vim')
+url='http://www.vim.org'
+depends=('gpm')
+makedepends=('python2')
+provides=('vim')
+conflicts=('vim' 'vim-runtime')
+pkgdesc='Vi Improved, console-only build with python2 support.'
+source=("https://vim.googlecode.com/archive/${repover}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/vim-${repover}/src"
+ autoconf
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var/lib/vim \
+ --with-features=huge \
+ --with-compiledby='Mikhail Burakov' \
+ --enable-gpm \
+ --enable-acl \
+ --with-x \
+ --disable-gui \
+ --enable-multibyte \
+ --enable-cscope \
+ --disable-netbeans \
+ --enable-perlinterp \
+ --enable-pythoninterp \
+ --disable-python3interp \
+ --disable-rubyinterp \
+ --disable-luainterp
+ make
+}
+
+package() {
+ cd "${srcdir}/vim-${repover}"
+ make -j1 DESTDIR="${pkgdir}" install
+
+ # provided by (n)vi in core
+ rm "${pkgdir}"/usr/bin/{ex,view}
+
+ # delete some manpages
+ find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ while read _mandir; do
+ cd ${_mandir}
+ rm -f ex.1 view.1 # provided by (n)vi
+ rm -f evim.1 # this does not make sense if we have no GUI
+ done
+
+ # license
+ install -Dm644 "${srcdir}/vim-${repover}/runtime/doc/uganda.txt" \
+ "${pkgdir}/usr/share/licenses/vim/license.txt"
+}