summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtěch Aschenbrenner2015-07-15 12:16:07 +0200
committerVojtěch Aschenbrenner2015-07-15 12:16:07 +0200
commit95330e2cd0847757cde028df79cc2c57ad4a8ef4 (patch)
tree00e1cbb1ec21387ce8b0b9b97dfd7d232894dbbb
downloadaur-95330e2cd0847757cde028df79cc2c57ad4a8ef4.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8185cd397a5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-opencl
+ pkgdesc = Vim plugin for syntax checking and highliting for OpenCL files.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/petRUShka/vim-opencl
+ arch = any
+ groups = vim-plugins
+ license = UNKNOWN
+ optdepends = vim-syntastic: enable syntax checker 1/2
+ optdepends = clcc: enable syntax checker 2/2
+ source = https://github.com/petRUShka/vim-opencl/archive/master.zip
+ sha512sums = SKIP
+
+pkgname = vim-opencl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba8d9a88d303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vojtěch Aschenbrenner <v@asch.cz>
+
+pkgname=vim-opencl
+pkgver=1
+pkgrel=1
+pkgdesc="Vim plugin for syntax checking and highliting for OpenCL files."
+arch=('any')
+url="https://github.com/petRUShka/vim-opencl"
+license=('UNKNOWN')
+groups=('vim-plugins')
+source=("https://github.com/petRUShka/vim-opencl/archive/master.zip")
+sha512sums=('SKIP')
+
+optdepends=('vim-syntastic: enable syntax checker 1/2'
+ 'clcc: enable syntax checker 2/2')
+
+package() {
+ cd "$srcdir/$pkgname-master"
+ install -m 644 -D "ftdetect/opencl.vim" "${pkgdir}/usr/share/vim/vimfiles/ftdetect/opencl.vim"
+ install -m 644 -D "ftplugin/opencl.vim" "${pkgdir}/usr/share/vim/vimfiles/ftplugin/opencl.vim"
+ install -m 644 -D "indent/opencl.vim" "${pkgdir}/usr/share/vim/vimfiles/indent/opencl.vim"
+ install -m 644 -D "syntax/opencl.vim" "${pkgdir}/usr/share/vim/vimfiles/syntax/opencl.vim"
+ install -m 644 -D "syntax_checkers/opencl.vim" "${pkgdir}/usr/share/vim/vimfiles/syntax_checkers/opencl.vim"
+}
+
+# vim:set ts=2 sw=2 et: