summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2022-07-10 01:44:06 +0200
committerXyne2022-07-10 01:44:06 +0200
commit1630aa0954ce0a6b0325bf81f20f294be9a22ad2 (patch)
tree34e78e33c50718618cacb08de56661097ef33bde
parent59e9013d25664735728795c9eb4dfaa98cf021b2 (diff)
downloadaur-1630aa0954ce0a6b0325bf81f20f294be9a22ad2.tar.gz
Fix source URL and update pkgver()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5798667f0a74..64a37c355d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = vim-pandoc-git
pkgdesc = plugin for writing and editing documents in Pandoc's extended markdown
- pkgver = 1631042682
+ pkgver = 2.0.r427.gfcdb70e
pkgrel = 1
url = https://github.com/vim-pandoc/vim-pandoc
arch = any
license = MIT
depends = vim
- source = git://github.com/vim-pandoc/vim-pandoc.git
+ source = git+https://github.com/vim-pandoc/vim-pandoc.git
sha512sums = SKIP
pkgname = vim-pandoc-git
diff --git a/PKGBUILD b/PKGBUILD
index 82f90b50b9c2..1bc80941ea7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
_pkgname=vim-pandoc
pkgname=vim-pandoc-git
-pkgver=1631042682
+pkgver=2.0.r427.gfcdb70e
pkgrel=1
pkgdesc="plugin for writing and editing documents in Pandoc's extended markdown"
arch=('any')
-#url='http://www.vim.org/scripts/script.php?script_id=3730'
url='https://github.com/vim-pandoc/vim-pandoc'
license=('MIT')
depends=('vim')
-
-source=('git://github.com/vim-pandoc/vim-pandoc.git')
+source=('git+https://github.com/vim-pandoc/vim-pandoc.git')
sha512sums=('SKIP')
pkgver() {
- cd -- "$srcdir/$_pkgname"
- git log -n1 --pretty=format:%ct
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$_pkgname"
install -dm755 "$pkgdir/usr/share/vim/vimfiles"
find * -maxdepth 0 -type d -exec cp -R -t "$pkgdir/usr/share/vim/vimfiles" '{}' \+
}