summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtěch Aschenbrenner2015-07-15 12:23:31 +0200
committerVojtěch Aschenbrenner2015-07-15 12:23:31 +0200
commit5c1ae3217324dc176ccce466d6857d4599f84ee3 (patch)
tree67120a981807a78df7a899bd843fa0c1474cebf9
downloadaur-5c1ae3217324dc176ccce466d6857d4599f84ee3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71ca170b00fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-pandoc-syntax-git
+ pkgdesc = syntax plugin for Pandoc's extended markdown
+ pkgver = 1434938917
+ pkgrel = 1
+ url = https://github.com/vim-pandoc/vim-pandoc-syntax
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = vim
+ provides = vim-pandoc-syntax
+ conflicts = vim-pandoc-syntax
+ source = git://github.com/vim-pandoc/vim-pandoc-syntax.git
+ sha512sums = SKIP
+
+pkgname = vim-pandoc-syntax-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b979f63af7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+_pkgname=vim-pandoc-syntax
+pkgname=vim-pandoc-syntax-git
+pkgver=1434938917
+pkgrel=1
+pkgdesc="syntax plugin for Pandoc's extended markdown"
+arch=('any')
+url='https://github.com/vim-pandoc/vim-pandoc-syntax'
+license=('unknown')
+depends=('vim')
+makedepends=('git')
+provides=('vim-pandoc-syntax')
+conflicts=('vim-pandoc-syntax')
+
+source=('git://github.com/vim-pandoc/vim-pandoc-syntax.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd -- "$srcdir/$_pkgname"
+ git log -n1 --pretty=format:%ct
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/vim/vimfiles"
+ find * -maxdepth 0 -type d -exec cp -R -t "$pkgdir/usr/share/vim/vimfiles" '{}' \+
+}