summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2016-07-13 09:18:50 +0200
committerSébastien Leduc2016-07-13 09:18:50 +0200
commit67fd89f82c7982e32a3aac8a5bf0a31d1c2c2d5f (patch)
treede507de9b5bd48762ab8e4252031ac309b1108f2
parent24b5328ea44c481c142c0a7b7540c67b6ad0d577 (diff)
downloadaur-67fd89f82c7982e32a3aac8a5bf0a31d1c2c2d5f.tar.gz
Update to 1.1 and fix for pycodestyle
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f1e96763c0a..26aa9751c592 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# lun. juil. 11 08:02:07 UTC 2016
+# mer. juil. 13 07:18:08 UTC 2016
pkgbase = vim-pep8
pkgdesc = A PEP 8 Python source file checker for Vim
- pkgver = 0.3.1
- pkgrel = 3
+ pkgver = 1.1
+ pkgrel = 1
url = http://www.vim.org/scripts/script.php?script_id=2914
arch = any
groups = vim-plugins
license = unknown
depends = vim
depends = python-pycodestyle
- source = pep8.vim::http://www.vim.org/scripts/download_script.php?src_id=14366
- md5sums = 393df8ac20d34f2ea8ec48420eac414e
+ source = https://github.com/nvie/vim-pep8/archive/1.1.tar.gz
+ md5sums = 7b36dd34665495110a8627131e83a730
pkgname = vim-pep8
diff --git a/PKGBUILD b/PKGBUILD
index 0e1b5d2d0255..d6260ff38f3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
# Contributor: Adam Russell <adamlr6+arch@gmail.com>
pkgname=vim-pep8
-pkgver=0.3.1
-pkgrel=3
-_scriptid=14366
+pkgver=1.1
+pkgrel=1
pkgdesc="A PEP 8 Python source file checker for Vim"
arch=('any')
url="http://www.vim.org/scripts/script.php?script_id=2914"
license=('unknown')
depends=('vim' 'python-pycodestyle')
groups=('vim-plugins')
-source=(pep8.vim::"http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
-md5sums=('393df8ac20d34f2ea8ec48420eac414e')
+source=("https://github.com/nvie/vim-pep8/archive/${pkgver}.tar.gz")
+md5sums=('7b36dd34665495110a8627131e83a730')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i -e 's/s:pep8_cmd="pep8"/s:pep8_cmd="pycodestyle"/g' \
+ "ftplugin/python_pep8.vim"
+
+}
package() {
- cd "$srcdir"
- local _installpath="${pkgdir}/usr/share/vim/vimfiles"
- install -D -m644 pep8.vim \
- ${_installpath}/ftplugin/python/pep8.vim
+ cd "$srcdir/${pkgname}-${pkgver}"
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -D -m644 ftplugin/python_pep8.vim \
+ ${_installpath}/ftplugin/python/python_pep8.vim
}
+# vim:set ts=2 sw=2 et: