summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commite11173c1ea8fb26ee6d81adb1d27c79dce006f78 (patch)
treefabd1fec30327cc1331ca2207b9aa76f8519b845
downloadaur-e11173c1ea8fb26ee6d81adb1d27c79dce006f78.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--makefile.patch11
-rw-r--r--vimdoc.install24
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98de517d2589
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-perl-completion
+ pkgdesc = This perl omni completion support basic Moose syntax, variable name (array. hash .. ) completion, class method, object method completion, etc.
+ pkgver = 2.4.2
+ pkgrel = 2
+ url = http://www.vim.org/scripts/script.php?script_id=2852
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ license = custom:vim
+ depends = vim
+ source = perl-completion-2.4.2.zip::http://www.vim.org/scripts/download_script.php?src_id=13656
+ source = makefile.patch
+ sha256sums = 39cbfa8a836b605f10c4763e733f8686ed65f11b4a374284ee9235ae15872d7f
+ sha256sums = 48a67e36c5f61f79e3946045596a08eb4e0aca6eb267ef62e4b9c6fe3d685d20
+
+pkgname = vim-perl-completion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7aa93a45084c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
+
+pkgname=vim-perl-completion
+pkgver=2.4.2
+_srcid=13656
+pkgrel=2
+pkgdesc='This perl omni completion support basic Moose syntax, variable name (array. hash .. ) completion, class method, object method completion, etc.'
+arch=('i686' 'x86_64')
+url='http://www.vim.org/scripts/script.php?script_id=2852'
+license=('custom:vim')
+depends=('vim')
+install='vimdoc.install'
+source=(perl-completion-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid
+ makefile.patch)
+sha256sums=('39cbfa8a836b605f10c4763e733f8686ed65f11b4a374284ee9235ae15872d7f'
+ '48a67e36c5f61f79e3946045596a08eb4e0aca6eb267ef62e4b9c6fe3d685d20')
+
+build() {
+ cd "$srcdir"
+
+ patch -Np0 -i "$srcdir/makefile.patch"
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..e44f1fa9847e
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2011-12-04 13:17:58.000000000 +0100
++++ Makefile 2011-12-04 13:20:32.000000000 +0100
+@@ -133,7 +133,7 @@
+ DIRS=`ls -1F | grep / | sed -e 's/\///'`
+
+ # Runtime path to install:
+-VIMRUNTIME=~/.vim
++VIMRUNTIME=$(DESTDIR)/usr/share/vim/vimfiles
+
+ # Other Files to be added:
+ FILES=`ls -1 | grep '.vim$$'`
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..488184f0c2cb
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,24 @@
+vimdocinstall() {
+ echo -n "updating Vim help tags... "
+ usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+
+post_install() {
+ vimdocinstall
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*