summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2019-06-16 23:03:56 +0200
committerKrzysztof AS (3ED)2019-06-16 23:03:56 +0200
commite200a815931b8e99332331e3e1e00d5f55a3e171 (patch)
treed54e10973261b83aad220a672c38e9a5f2b25439
parente11173c1ea8fb26ee6d81adb1d27c79dce006f78 (diff)
downloadaur-e200a815931b8e99332331e3e1e00d5f55a3e171.tar.gz
dust is wiped
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--makefile.patch11
-rw-r--r--vimdoc.install24
4 files changed, 27 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98de517d2589..fa84d49c1dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = vim-perl-completion
- pkgdesc = This perl omni completion support basic Moose syntax, variable name (array. hash .. ) completion, class method, object method completion, etc.
- pkgver = 2.4.2
- pkgrel = 2
- url = http://www.vim.org/scripts/script.php?script_id=2852
- install = vimdoc.install
- arch = i686
- arch = x86_64
+ pkgdesc = perl omni completion support for basic Moose syntax, variable names (array, hash, ...), class methods, etc.
+ pkgver = 2.42
+ pkgrel = 1
+ url = https://www.vim.org/scripts/script.php?script_id=2852
+ arch = any
license = custom:vim
+ depends = perl
depends = vim
- source = perl-completion-2.4.2.zip::http://www.vim.org/scripts/download_script.php?src_id=13656
- source = makefile.patch
+ noextract = vim-perl-completion-2.42.zip
+ source = vim-perl-completion-2.42.zip::http://www.vim.org/scripts/download_script.php?src_id=13656
sha256sums = 39cbfa8a836b605f10c4763e733f8686ed65f11b4a374284ee9235ae15872d7f
- sha256sums = 48a67e36c5f61f79e3946045596a08eb4e0aca6eb267ef62e4b9c6fe3d685d20
pkgname = vim-perl-completion
diff --git a/PKGBUILD b/PKGBUILD
index 7aa93a45084c..f9cb0da46296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
+# Maintainer: 3ED <krzysztofas _at_ protonmail _dot_ com>
pkgname=vim-perl-completion
-pkgver=2.4.2
+pkgver=2.42
_srcid=13656
-pkgrel=2
-pkgdesc='This perl omni completion support basic Moose syntax, variable name (array. hash .. ) completion, class method, object method completion, etc.'
-arch=('i686' 'x86_64')
-url='http://www.vim.org/scripts/script.php?script_id=2852'
+pkgrel=1
+pkgdesc='perl omni completion support for basic Moose syntax, variable names (array, hash, ...), class methods, etc.'
+arch=('any')
+url='https://www.vim.org/scripts/script.php?script_id=2852'
license=('custom:vim')
-depends=('vim')
-install='vimdoc.install'
-source=(perl-completion-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid
- makefile.patch)
-sha256sums=('39cbfa8a836b605f10c4763e733f8686ed65f11b4a374284ee9235ae15872d7f'
- '48a67e36c5f61f79e3946045596a08eb4e0aca6eb267ef62e4b9c6fe3d685d20')
+depends=('perl' 'vim')
+source=("$pkgname-$pkgver.zip::http://www.vim.org/scripts/download_script.php?src_id=$_srcid")
+sha256sums=('39cbfa8a836b605f10c4763e733f8686ed65f11b4a374284ee9235ae15872d7f')
+noextract=("$pkgname-$pkgver.zip")
-build() {
- cd "$srcdir"
+package() {
+ cd "$srcdir"
+ _DESTDIR="$pkgdir/usr/share/vim/vimfiles/"
- patch -Np0 -i "$srcdir/makefile.patch"
+ install -dm755 "$_DESTDIR"
- make DESTDIR="$pkgdir" install
+ bsdtar -xf $pkgname-$pkgver.zip \
+ --exclude README.mkd.old \
+ --exclude Makefile \
+ --exclude config.mk \
+ --directory "$_DESTDIR"
}
diff --git a/makefile.patch b/makefile.patch
deleted file mode 100644
index e44f1fa9847e..000000000000
--- a/makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2011-12-04 13:17:58.000000000 +0100
-+++ Makefile 2011-12-04 13:20:32.000000000 +0100
-@@ -133,7 +133,7 @@
- DIRS=`ls -1F | grep / | sed -e 's/\///'`
-
- # Runtime path to install:
--VIMRUNTIME=~/.vim
-+VIMRUNTIME=$(DESTDIR)/usr/share/vim/vimfiles
-
- # Other Files to be added:
- FILES=`ls -1 | grep '.vim$$'`
diff --git a/vimdoc.install b/vimdoc.install
deleted file mode 100644
index 488184f0c2cb..000000000000
--- a/vimdoc.install
+++ /dev/null
@@ -1,24 +0,0 @@
-vimdocinstall() {
- echo -n "updating Vim help tags... "
- usr/bin/vim --noplugin -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
- echo "done."
-}
-
-
-post_install() {
- vimdocinstall
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- vimdocinstall
-}
-
-op=$1
-shift
-
-$op $*