summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:16:17 +0200
committerPiotr Rogoża2015-06-14 16:16:17 +0200
commitd010e4fded89c55860114cc398383d736bfd3206 (patch)
tree9452d1ede6d6e7ccc64445d0ed71d0d7b1b02039
downloadaur-d010e4fded89c55860114cc398383d736bfd3206.tar.gz
Initial import
-rw-r--r--.AURINFO23
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
-rw-r--r--vimdoc.install23
4 files changed, 120 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5d6bf43929fc
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,23 @@
+pkgbase = vim-perl-support
+ pkgdesc = Perl-IDE offers easiest way to do all of the above, saving lot of time and keystrokes.
+ pkgver = 5.3.2
+ pkgrel = 2
+ url = http://vim.org/scripts/script.php?script_id=556
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = GPL2
+ depends = vim-runtime
+ depends = perl
+ depends = vim-vim-support
+ optdepends = perl-perl-tags: to generate Ctags style tags for Perl sourcecode
+ optdepends = perl-devel-smallprof: to run per-line Perl profiler
+ optdepends = perl-critic: Critique Perl source code for best-practices
+ optdepends = perl-devel-fastprof: to run "fast" perl per-line profiler
+ optdepends = perl-devel-nytprof: Powerful fast feature-rich perl source code profiler
+ optdepends = perl-tidy: Parses and beautifies perl source
+ source = vim-perl-support-5.3.2.zip::http://www.vim.org/scripts/download_script.php?src_id=22459
+ options = !emptydirs
+
+pkgname = vim-perl-support
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b521390cac15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vim-perl-support
+ pkgdesc = Perl-IDE offers easiest way to do all of the above, saving lot of time and keystrokes.
+ pkgver = 5.3.2
+ pkgrel = 2
+ url = http://vim.org/scripts/script.php?script_id=556
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = GPL2
+ depends = vim-runtime
+ depends = perl
+ depends = vim-vim-support
+ optdepends = perl-perl-tags: to generate Ctags style tags for Perl sourcecode
+ optdepends = perl-devel-smallprof: to run per-line Perl profiler
+ optdepends = perl-critic: Critique Perl source code for best-practices
+ optdepends = perl-devel-fastprof: to run "fast" perl per-line profiler
+ optdepends = perl-devel-nytprof: Powerful fast feature-rich perl source code profiler
+ optdepends = perl-tidy: Parses and beautifies perl source
+ options = !emptydirs
+ source = vim-perl-support-5.3.2.zip::http://www.vim.org/scripts/download_script.php?src_id=22459
+ sha256sums = 78544a59adb00af2e29d3b69816255b8671d57bbb9cba23b1236b4e2d6294be7
+
+pkgname = vim-perl-support
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58ec05f3f2f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100:
+
+pkgname=vim-perl-support
+pkgver=5.3.2
+_src_id=22459
+pkgrel=2
+pkgdesc='Perl-IDE offers easiest way to do all of the above, saving lot of time and keystrokes.'
+arch=('any')
+url='http://vim.org/scripts/script.php?script_id=556'
+license=('GPL2')
+groups=(vim-plugins)
+depends=(vim-runtime perl vim-vim-support)
+optdepends=(
+ 'perl-perl-tags: to generate Ctags style tags for Perl sourcecode'
+ 'perl-devel-smallprof: to run per-line Perl profiler'
+ 'perl-critic: Critique Perl source code for best-practices'
+ 'perl-devel-fastprof: to run "fast" perl per-line profiler'
+ 'perl-devel-nytprof: Powerful fast feature-rich perl source code profiler'
+ 'perl-tidy: Parses and beautifies perl source'
+)
+options=(!emptydirs)
+install='vimdoc.install'
+source=("$pkgname-$pkgver.zip::http://www.vim.org/scripts/download_script.php?src_id=$_src_id")
+
+package() {
+ cd "$srcdir"
+ _vim_dir='/usr/share/vim/vimfiles'
+
+ install -dm755 $pkgdir/$_vim_dir
+
+ tar -c ./ --exclude $pkgname-$pkgver.zip \
+ | tar -x -C $pkgdir/$_vim_dir
+
+ #mv $pkgdir/${_vim_dir}/README.perlsupport \
+ # $pkgdir/${_vim_dir}/perl-support/doc/README.perlsupport
+
+ #conflict with vim-vim-support
+ #rm -f $pkgdir/${_vim_dir}/{autoload/mmtemplates/core.vim,doc/templatesupport.txt}
+ rm -f "$pkgdir"/usr/share/vim/vimfiles/syntax/template.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/autoload/mmtemplates/core.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/doc/templatesupport.txt
+
+
+ #fix perm
+# find $pkgdir/$_vim_dir -type d -exec chmod 0755 '{}' ';'
+# chmod o+r $pkgdir/${_vim_dir}/perl-support/doc/*
+}
+sha256sums=('78544a59adb00af2e29d3b69816255b8671d57bbb9cba23b1236b4e2d6294be7')
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..66a417cca8ea
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,23 @@
+vimdocinstall() {
+ echo -n "updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_install() {
+ vimdocinstall
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*