summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2019-06-16 22:03:06 +0200
committerKrzysztof AS (3ED)2019-06-16 22:03:06 +0200
commitfff4c344b58359fbb1381a2fc87fd18e3174a85f (patch)
treeb77441967d6d93aedc269d3fd482be3a01223d64
parent95ff092f3b5eef793b4a95adfbc47a0dcc33270c (diff)
downloadaur-fff4c344b58359fbb1381a2fc87fd18e3174a85f.tar.gz
fixes for files confilicts
-rw-r--r--.AURINFO23
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 26 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 5d6bf43929fc..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,23 +0,0 @@
-pkgbase = vim-perl-support
- pkgdesc = Perl-IDE offers easiest way to do all of the above, saving lot of time and keystrokes.
- pkgver = 5.3.2
- pkgrel = 2
- url = http://vim.org/scripts/script.php?script_id=556
- install = vimdoc.install
- arch = any
- groups = vim-plugins
- license = GPL2
- depends = vim-runtime
- depends = perl
- depends = vim-vim-support
- optdepends = perl-perl-tags: to generate Ctags style tags for Perl sourcecode
- optdepends = perl-devel-smallprof: to run per-line Perl profiler
- optdepends = perl-critic: Critique Perl source code for best-practices
- optdepends = perl-devel-fastprof: to run "fast" perl per-line profiler
- optdepends = perl-devel-nytprof: Powerful fast feature-rich perl source code profiler
- optdepends = perl-tidy: Parses and beautifies perl source
- source = vim-perl-support-5.3.2.zip::http://www.vim.org/scripts/download_script.php?src_id=22459
- options = !emptydirs
-
-pkgname = vim-perl-support
-
diff --git a/PKGBUILD b/PKGBUILD
index df46b35f67d9..d45c2a4eab23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=vim-perl-support
pkgver=5.4
_src_id=24473
-pkgrel=1
+pkgrel=2
pkgdesc='Perl-IDE offers easiest way to do all of the above, saving lot of time and keystrokes.'
arch=('any')
url='https://www.vim.org/scripts/script.php?script_id=556'
license=('GPL2')
groups=(vim-plugins)
-depends=(perl vim-vim-support)
+depends=('perl' 'vim-vim-support>=2.4')
optdepends=(
'perl-perl-tags: to generate Ctags style tags for Perl sourcecode'
'perl-devel-smallprof: to run per-line Perl profiler'
@@ -31,9 +31,13 @@ package() {
install -dm755 "$pkgdir/$_vim_dir"
bsdtar -xf $pkgname-$pkgver.zip \
- --exclude syntax/template.vim \
+ --exclude autoload/mmtemplates/config.vim \
--exclude autoload/mmtemplates/core.vim \
+ --exclude autoload/mmtemplates/wizard.vim \
--exclude doc/templatesupport.txt \
+ --exclude ftdetect/template.vim \
+ --exclude ftplugin/template.vim \
+ --exclude syntax/template.vim \
--directory "$pkgdir/$_vim_dir"
# note: exclusions should be inside vim-vim-support package