summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArcher7772015-06-30 12:53:00 +0500
committerArcher7772015-06-30 12:53:00 +0500
commite18522209fbad4d03f910c10f7a458c7e5f5b5e9 (patch)
treecd1e32d99a109b52672c3847b033fa183e1211bf
downloadaur-e18522209fbad4d03f910c10f7a458c7e5f5b5e9.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD43
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fded84c8428
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-perlomni-git
+ pkgdesc = perl omnicompletion for vim (including base class function compleltions .. etc)
+ pkgver = 2.5
+ pkgrel = 2
+ url = https://github.com/c9s/perlomni.vim
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = vim
+ source = git+https://github.com/c9s/perlomni.vim
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 3c5991a7e0696f045904ea61828754fe
+
+pkgname = vim-perlomni-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6fc2d07e9baf
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2010 <Cornelius (c9s)>
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e81c0c0244c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Archer777 <NAME at gmx dot com>
+
+_gitname='perlomni.vim'
+pkgname='vim-perlomni-git'
+pkgver=2.5
+pkgrel=2
+pkgdesc='perl omnicompletion for vim (including base class function compleltions .. etc)'
+arch=('any')
+url="https://github.com/c9s/${_gitname}"
+license=('MIT')
+depends=('vim')
+makedepends=('git')
+source=("git+https://github.com/c9s/${_gitname}"
+ "LICENSE")
+md5sums=('SKIP'
+ '3c5991a7e0696f045904ea61828754fe')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}/ftplugin/perl/"
+ cat perlomni.vim | grep 'Version' | sed 's/^.*: //'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -Dm644 autoload/perlomni/data.vim \
+ ${installpath}/autoload/perlomni/data.vim
+
+ install -m644 autoload/perlomni/util.vim \
+ ${installpath}/autoload/perlomni/util.vim
+
+ install -Dm644 ftplugin/perl/perlomni.vim \
+ ${installpath}/ftplugin/perl/perlomni.vim
+
+ install -Dm644 bin/grep-objvar.pl \
+ ${installpath}/bin/grep-objvar.pl
+
+ install -m644 bin/grep-pattern.pl \
+ ${installpath}/bin/grep-pattern.pl
+
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}