summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroozyslug2015-07-10 21:55:33 +0530
committeroozyslug2015-07-10 21:55:33 +0530
commit63434fa69841386ef54188ab5d9700229331a778 (patch)
tree13f67b6abfafdd2c8b226d0be3434d4f19b6302c
downloadaur-63434fa69841386ef54188ab5d9700229331a778.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE-MIT.txt7
-rw-r--r--PKGBUILD30
-rw-r--r--plug.vimrc27
-rw-r--r--vim-plug.install17
5 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cbad4f140d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vim-plug
+ pkgdesc = A vim plugin manager
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = http://github.com/junegunn/vim-plug
+ install = vim-plug.install
+ arch = any
+ license = MIT
+ depends = vim
+ provides = vim-plug
+ conflicts = vim-plug-git
+ source = https://github.com/junegunn/vim-plug/archive/0.7.2.tar.gz
+ source = LICENSE-MIT.txt
+ source = plug.vimrc
+ sha512sums = c9d2954ad8501390e5c72ddefa4b2ff75843b850a5f330580c347ff9186e3e30c0bcd42bedd1381cf4ea55532a08e4d757b7a89d61726f9e1d38729631c24e78
+ sha512sums = aef00f3c6c9e529f40180f5e05a0c06dc614df3419969469baf574ed85611321c34415c3c731ffd5f6dfcf4ec9a34698b7851e2d9b5a46efa8de2410aa626fa8
+ sha512sums = 8e15c2074d0ce36daa0568167bcbcaf1038b8f65edcab661c9d41a9a18714b27accab28f5065408852329827ff4c84c03102c17bd542962cde1f057e88c4044c
+
+pkgname = vim-plug
+
diff --git a/LICENSE-MIT.txt b/LICENSE-MIT.txt
new file mode 100644
index 000000000000..003904d99532
--- /dev/null
+++ b/LICENSE-MIT.txt
@@ -0,0 +1,7 @@
+Copyright (C) 2010 http://github.com/gmarik
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1454e08a7dab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: oozyslug <oozyslug at gmail dot com>
+# Contributor: oozyslug <oozyslug at gmail dot com>
+# Submitter: oozyslug <oozyslug at gmail dot com>
+
+pkgname=vim-plug
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A vim plugin manager"
+arch=('any')
+url="http://github.com/junegunn/vim-plug"
+license=('MIT')
+depends=('vim')
+conflicts=('vim-plug-git')
+provides=('vim-plug')
+source=(https://github.com/junegunn/vim-plug/archive/0.7.2.tar.gz
+ LICENSE-MIT.txt
+ plug.vimrc
+ )
+
+sha512sums=('c9d2954ad8501390e5c72ddefa4b2ff75843b850a5f330580c347ff9186e3e30c0bcd42bedd1381cf4ea55532a08e4d757b7a89d61726f9e1d38729631c24e78'
+ 'aef00f3c6c9e529f40180f5e05a0c06dc614df3419969469baf574ed85611321c34415c3c731ffd5f6dfcf4ec9a34698b7851e2d9b5a46efa8de2410aa626fa8'
+ '8e15c2074d0ce36daa0568167bcbcaf1038b8f65edcab661c9d41a9a18714b27accab28f5065408852329827ff4c84c03102c17bd542962cde1f057e88c4044c'
+ )
+install=vim-plug.install
+
+package() {
+ install -Dm 644 ${pkgname}-${pkgver}/plug.vim ${pkgdir}/usr/share/vim/vimfiles/autoload/plug.vim
+ install -Dm 644 LICENSE-MIT.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm 644 plug.vimrc ${pkgdir}/usr/share/vim-plug/vimrc.sample
+}
diff --git a/plug.vimrc b/plug.vimrc
new file mode 100644
index 000000000000..094d5e442fa1
--- /dev/null
+++ b/plug.vimrc
@@ -0,0 +1,27 @@
+call plug#begin('~/.vim/plugged')
+
+" Make sure you use single quotes
+ Plug 'junegunn/seoul256.vim'
+ Plug 'junegunn/vim-easy-align'
+
+" Group dependencies, vim-snippets depends on ultisnips
+ Plug 'SirVer/ultisnips' | Plug 'honza/vim-snippets'
+
+" On-demand loading
+ Plug 'scrooloose/nerdtree', { 'on': 'NERDTreeToggle' }
+ Plug 'tpope/vim-fireplace', { 'for': 'clojure' }
+
+" Using git URL
+ Plug 'https://github.com/junegunn/vim-github-dashboard.git'
+
+" Plugin options
+ Plug 'nsf/gocode', { 'tag': 'v.20150303', 'rtp': 'vim' }
+
+" Plugin outside ~/.vim/plugged with post-update hook
+ Plug 'junegunn/fzf', { 'dir': '~/.fzf', 'do': 'yes \| ./install' }
+
+" Unmanaged plugin (manually installed and updated)
+ Plug '~/my-prototype-plugin'
+
+call plug#end()
+
diff --git a/vim-plug.install b/vim-plug.install
new file mode 100644
index 000000000000..9b11b31ab106
--- /dev/null
+++ b/vim-plug.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo "
+ >>> To use vim-plug, please check the file /usr/share/vim-plug/vimrc.sample
+ >>> and update your ~/.vimrc file, accordingly
+ "
+}
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo "
+ >>> Please remember to remove plugins from your ~/.vimrc file
+ >>> and from your ~/.vim directory!
+ "
+}
+