summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-26 20:45:10 +0800
committerSainnhepark2020-07-26 20:45:10 +0800
commit058ba66d1cb1d1859338f6433169c4014f129285 (patch)
tree8fa59c01967644644066a83e177c2bc229a6c45b
downloadaur-058ba66d1cb1d1859338f6433169c4014f129285.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dafd32ac376
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-polyglot-git
+ pkgdesc = A solid language pack for Vim.
+ pkgver = r540.56121b4
+ pkgrel = 1
+ url = https://github.com/sheerun/vim-polyglot
+ arch = any
+ license =
+ makedepends = git
+ depends = vim
+ provides = vim-polyglot
+ conflicts = vim-polyglot
+ source = git+https://github.com/sheerun/vim-polyglot.git
+ sha256sums = SKIP
+
+pkgname = vim-polyglot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce991a97a463
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=vim-polyglot-git
+pkgver=r540.56121b4
+pkgrel=1
+pkgdesc='A solid language pack for Vim.'
+arch=('any')
+url='https://github.com/sheerun/vim-polyglot'
+license=('')
+depends=('vim')
+makedepends=('git')
+provides=('vim-polyglot')
+conflicts=('vim-polyglot')
+source=('git+https://github.com/sheerun/vim-polyglot.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/vim-polyglot"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/vim-polyglot"
+ find after autoload compiler ctags extras ftdetect ftplugin indent syntax -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/pack/vim-polyglot/start/vim-polyglot/{}" \;
+}
+