summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin UX2018-08-15 21:16:06 +0800
committerLin UX2018-08-15 21:16:06 +0800
commit802193d11afa724d1a59ae1c754744bbe0605774 (patch)
tree72a4bad8b57e63e5b12ab7647fe5aa344a3822a2
downloadaur-802193d11afa724d1a59ae1c754744bbe0605774.tar.gz
start python programming under vim so package this one
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4de8bb2d6e8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-python-mode
+ pkgdesc = A vim plugin that make vim into python IDE
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/python-mode/python-mode
+ arch = any
+ groups = vim-plugins
+ license = LGPL3
+ depends = vim
+ depends = python
+ optdepends = python-pylint
+ optdepends = python-rope
+ source = https://github.com/python-mode/python-mode/archive/0.9.2.tar.gz
+ sha256sums = 1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd
+
+pkgname = vim-python-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2d04fb123e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Cravix <dr dot neemous at gmail dot com>
+# Based on community/vim-jedi PKGBUILD by Levente Polyak <anthraxx[at]archlinux[dot]org>
+# check part doesn't work so directly removed it :p if you know how to fix it please tell me :)
+
+pkgname=vim-python-mode
+_pkgname=python-mode
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='A vim plugin that make vim into python IDE'
+arch=('any')
+license=('LGPL3')
+url='https://github.com/python-mode/python-mode'
+depends=('vim' 'python')
+optdepends=('python-pylint' 'python-rope')
+groups=('vim-plugins')
+source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=(1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd)
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles"
+ cp -dpr --no-preserve=ownership pymode "${pkgdir}/usr/share/vim/vimfiles"
+ cp -dpr --no-preserve=ownership after "${pkgdir}/usr/share/vim/vimfiles/after"
+ cp -dpr --no-preserve=ownership autoload "${pkgdir}/usr/share/vim/vimfiles/autoload"
+ cp -dpr --no-preserve=ownership doc "${pkgdir}/usr/share/vim/vimfiles/doc"
+ cp -dpr --no-preserve=ownership ftplugin "${pkgdir}/usr/share/vim/vimfiles/ftplugin"
+ cp -dpr --no-preserve=ownership plugin "${pkgdir}/usr/share/vim/vimfiles/plugin"
+ cp -dpr --no-preserve=ownership syntax "${pkgdir}/usr/share/vim/syntax"
+
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}