summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelixoid2016-08-30 18:03:47 +0300
committerfelixoid2016-08-30 18:03:47 +0300
commite10449285f7e393c18067e6e52dbef736ed14643 (patch)
treefda42756795d5ec7f58f0476faa23024bc21047b
downloadaur-e10449285f7e393c18067e6e52dbef736ed14643.tar.gz
restore python-mode from old aur with refactoring
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--install19
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..346d1285dfdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Aug 30 15:02:47 UTC 2016
+pkgbase = vim-python-mode-git
+ pkgdesc = Python-mode is a vim plugin that allows you to use the pylint, rope, pydoc library in vim to provide features like python code looking for bugs, refactoring and some other useful things.
+ pkgver = 0.8.1.r2.g4bda303
+ pkgrel = 1
+ url = https://github.com/klen/python-mode
+ install = install
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = vim
+ depends = python2
+ source = vim-python-mode-git::git+https://github.com/klen/python-mode#branch=master
+ sha256sums = SKIP
+
+pkgname = vim-python-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c376ecd18d78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kirill Klenov <horneds@gmail.com>
+# Contributor: Mikhail felixoid Shiryaev <mr dot felixoid na gmail com>
+
+pkgname=vim-python-mode-git
+pkgver=0.8.1.r2.g4bda303
+pkgrel=1
+pkgdesc='Python-mode is a vim plugin that allows you to use the pylint, rope, pydoc library in vim to provide features like python code looking for bugs, refactoring and some other useful things.'
+arch=('any')
+license=('LGPL3')
+url='https://github.com/klen/python-mode'
+install='install'
+depends=('vim' 'python2')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/klen/python-mode#branch=master")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+
+package() {
+
+ cd ${srcdir}/${pkgname}
+ rm AUTHORS Changelog.rst COPYING Gemfile logo.png Makefile Rakefile README.rst
+ install -d ${pkgdir}/usr/share/vim/vimfiles/
+ cp -R * ${pkgdir}/usr/share/vim/vimfiles/
+
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/install b/install
new file mode 100644
index 000000000000..988fe177daa2
--- /dev/null
+++ b/install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*