summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2015-08-29 17:38:25 +0200
committerPeter Mattern2015-08-29 17:38:25 +0200
commit33b7173fc79bbbf0f801aaa7724dbadd4cad498f (patch)
tree2f7e1ddfe3c42cd547a3127cbc338e10aeb2cb04
downloadaur-33b7173fc79bbbf0f801aaa7724dbadd4cad498f.tar.gz
initial commit
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD90
-rw-r--r--vim-qt-git.install11
-rw-r--r--vim-qt.desktop11
4 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..58f5e69f59e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = vim-qt-qt5-git
+ pkgdesc = An experimental Qt GUI for Vim. Built against Qt5.
+ pkgver = 20130201.47.ge1ebbe8
+ pkgrel = 1
+ url = https://bitbucket.org/equalsraf/vim-qt
+ install = vim-qt-git.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ license = custom:vim
+ makedepends = git
+ makedepends = lua
+ makedepends = python
+ makedepends = python2
+ makedepends = ruby
+ depends = gpm
+ depends = gawk
+ depends = qt5-base
+ depends = libxkbcommon-x11
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ optdepends = lua: Lua interpreter
+ optdepends = python: Python 3 interpreter
+ optdepends = python2: Python 2 interpreter
+ optdepends = ruby: Ruby interpreter
+ provides = vim-qt
+ provides = vim-qt-git
+ provides = qvim
+ provides = vim-runtime
+ provides = vim
+ provides = vim-minimal
+ provides = vim-python3
+ provides = xxd
+ conflicts = vim-qt
+ conflicts = vim-qt-git
+ conflicts = qvim
+ conflicts = vim-runtime
+ conflicts = vim
+ conflicts = vim-minimal
+ conflicts = vim-python3
+ conflicts = gvim
+ conflicts = gvim-python3
+ source = git+https://github.com/equalsraf/vim-qt.git
+ source = vim-qt.desktop
+ sha256sums = SKIP
+ sha256sums = ad2fe7c3d8436d2f62e251b9081512e37726c024ed4aac9534764749904f68d6
+
+pkgname = vim-qt-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..1ac2eae15cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+# Note
+# Unlike package qvim this one is using Vim code as imported by / into vim-Qt
+# upstream and does not rely on package vim-runtime.
+# This seemed reasonable to me with regards to performing tests as one main
+# purpose of VCS packages.
+
+_pkgname=vim-qt
+pkgname=$_pkgname-qt5-git
+pkgver=20130201.47.ge1ebbe8
+pkgrel=1
+pkgdesc="An experimental Qt GUI for Vim. Built against Qt5."
+arch=("i686" "x86_64")
+url="https://bitbucket.org/equalsraf/vim-qt"
+license=("unknown" "custom:vim")
+depends=("gpm" "gawk" "qt5-base" "libxkbcommon-x11" "hicolor-icon-theme" "gtk-update-icon-cache")
+optdepends=("lua: Lua interpreter" "python: Python 3 interpreter" "python2: Python 2 interpreter"
+ "ruby: Ruby interpreter")
+makedepends=("git" "lua" "python" "python2" "ruby")
+provides=("$_pkgname" "$_pkgname-git" "qvim"
+ "vim-runtime" "vim" "vim-minimal" "vim-python3"
+ "xxd")
+conflicts=("$_pkgname" "$_pkgname-git" "qvim"
+ "vim-runtime" "vim" "vim-minimal" "vim-python3" "gvim" "gvim-python3")
+install=vim-qt-git.install
+source=("git+https://github.com/equalsraf/vim-qt.git"
+ "vim-qt.desktop")
+sha256sums=("SKIP"
+ "ad2fe7c3d8436d2f62e251b9081512e37726c024ed4aac9534764749904f68d6")
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed "s/^package.//;s/-/./g"
+}
+
+prepare() {
+ cd $_pkgname
+ # set global configuration file to /etc/vimrc
+ sed -i 's|^.*\(#define SYS_VIMRC_FILE.*"\) .*$|\1|' src/feature.h
+}
+
+build() {
+
+ cd $_pkgname
+
+ ./configure \
+ --enable-fail-if-missing \
+ --with-compiledby='Arch Linux AUR' \
+ --prefix=/usr \
+ --enable-gui=qt \
+ --with-qt-qmake=/usr/bin/qmake-qt5 \
+ --with-features=huge \
+ --enable-cscope \
+ --enable-multibyte \
+ --enable-luainterp=dynamic \
+ --enable-perlinterp=dynamic \
+ --enable-pythoninterp=dynamic \
+ --enable-python3interp=dynamic \
+ --enable-rubyinterp=dynamic
+
+ make
+
+}
+
+package() {
+
+ # actual installation
+ cd $_pkgname
+ make DESTDIR=$pkgdir install
+
+ # desktop entry file and corresponding icon
+ install -D -m644 ../vim-qt.desktop $pkgdir/usr/share/applications/vim-qt.desktop
+ install -D -m644 src/qt/icons/vim-qt.png $pkgdir/usr/share/icons/hicolor/64x64/apps/vim-qt.png
+
+ # add link 'qvim'
+ cd $pkgdir/usr/bin ; ln -sf vim qvim
+
+ # remove ex / view and corresponding main pages (normally provided by package 'vi' on Arch Linux)
+ cd $pkgdir/usr/bin ; rm ex view
+ find $pkgdir/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ while read _mandir; do
+ cd ${_mandir}
+ rm -f ex.1 view.1
+ done
+
+ # add Vim license
+ install -D -m644 $srcdir/$_pkgname/runtime/doc/uganda.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE.vim
+}
diff --git a/vim-qt-git.install b/vim-qt-git.install
new file mode 100644
index 00000000000..272ceaacbab
--- /dev/null
+++ b/vim-qt-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/vim-qt.desktop b/vim-qt.desktop
new file mode 100644
index 00000000000..3835c549841
--- /dev/null
+++ b/vim-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=vim-Qt
+GenericName=An experimental Qt GUI for Vim
+Comment=Qt UI written in Qt similar to its GTK counterpart gvim
+Icon=vim-qt
+Categories=Utility;
+TryExec=qvim
+Exec=qvim
+Terminal=false
+StartupNotify=false