summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Böger2017-09-16 23:33:41 +0200
committerLukas Böger2017-09-16 23:33:41 +0200
commitb7db476bd236c89764016c3d6796f83ec9222aa5 (patch)
tree8f5370b46485e8c204327276f1c607a982add405
downloadaur-b7db476bd236c89764016c3d6796f83ec9222aa5.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--vimdoc.install14
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56588b4b5b3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-quickscope
+ pkgdesc = Highlight which characters to target for f, F and family
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/unblevable/quick-scope
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim>=7.0
+ source = https://github.com/unblevable/quick-scope/archive/v1.1.1.tar.gz
+ sha256sums = 820a4340f51722cf59a44a17832d209b44e5ba9e83f89d6a8b0931cc8368ac1d
+
+pkgname = vim-quickscope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5941213d826d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lukas Böger <dev AT lboeger DOT de>
+
+pkgname=vim-quickscope
+_name=quick-scope
+pkgver=1.1.1
+pkgrel=1
+
+pkgdesc='Highlight which characters to target for f, F and family'
+arch=('any')
+url='https://github.com/unblevable/quick-scope'
+
+groups=('vim-plugins')
+depends=('vim>=7.0')
+license=('MIT')
+
+source=("${url}/archive/v${pkgver}.tar.gz")
+install='vimdoc.install'
+sha256sums=('820a4340f51722cf59a44a17832d209b44e5ba9e83f89d6a8b0931cc8368ac1d')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ install -Dm644 doc/${_name}.txt "${pkgdir}/usr/share/vim/vimfiles/doc/${_name}.txt"
+ install -Dm644 plugin/${_name/-/_}.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/${_name/-/_}.vim"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..8edb014758eb
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}