summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-10-13 00:28:05 +0200
committerKr1ss2020-10-13 00:28:05 +0200
commit18f80ade3c50d675d4815a0c123f1ce32198359d (patch)
tree56cf2ace4901513090d8e105f220ef8050cd5303
downloadaur-18f80ade3c50d675d4815a0c123f1ce32198359d.tar.gz
initial upload: vim-rhubarb-git r74.5130596-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--vimdoc.install13
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e08b61e085b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vim-rhubarb-git
+ pkgdesc = Github extension for vim-fugitive
+ pkgver = r74.5130596
+ pkgrel = 1
+ url = https://github.com/tpope/vim-rhubarb
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim
+ depends = vim-fugitive
+ optdepends = hub: used instead of git if installed
+ provides = vim-rhubarb
+ conflicts = vim-rhubarb
+ source = git+https://github.com/tpope/vim-rhubarb.git
+ sha256sums = SKIP
+
+pkgname = vim-rhubarb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75fcd634e7e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer : Kr1ss $(tr +- .@ <<<'<kr1ss+x-yandex+com>')
+
+
+pkgname=vim-rhubarb-git
+
+groups=('vim-plugins')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgver=r74.5130596
+pkgrel=1
+
+pkgdesc='Github extension for vim-fugitive'
+arch=('any')
+url="https://github.com/tpope/${pkgname%-git}"
+license=('custom:vim')
+
+makedepends=('git')
+depends=('vim' 'vim-fugitive')
+optdepends=('hub: used instead of git if installed')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+
+install=vimdoc.install
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm644 plugin/rhubarb.vim -t"$pkgdir/usr/share/vim/vimfiles/plugin/"
+ install -Dm644 autoload/rhubarb.vim -t"$pkgdir/usr/share/vim/vimfiles/autoload/"
+ install -Dm644 doc/rhubarb.txt -t"$pkgdir/usr/share/vim/vimfiles/doc/"
+ install -Dm644 README.markdown -t"$pkgdir/usr/share/doc/${pkgname%-git}"
+}
+
+
+# vim: ts=4 sw=4 et ft=PKGBUILD:
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..3a62343e7c15
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo -n 'Updating vim help tags ...'
+ /usr/bin/vim --noplugin -u NONE -U NONE -c'helptags /usr/share/vim/doc' -cq >&/dev/null
+ echo ' done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}