summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago Nascimento2019-07-09 07:40:12 +0000
committerTiago Nascimento2019-07-09 07:40:12 +0000
commitcfc04cccc393042e22d4b77a272c95fe49366acb (patch)
tree85d0e0f7f24b2f680d907ceb3ca3011f88168026
downloadaur-cfc04cccc393042e22d4b77a272c95fe49366acb.tar.gz
created package for RON syntax in vim
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60bb848f707a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-ron-git
+ pkgdesc = RON syntax highlighting for Vim.
+ pkgver = r4.2ec8a5d
+ pkgrel = 1
+ url = https://github.com/ron-rs/ron.vim
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = git
+ depends = vim
+ provides = vim-ron
+ conflicts = vim-ron
+ source = git+https://github.com/ron-rs/vim-ron.git
+ md5sums = SKIP
+
+pkgname = vim-ron-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55122d1eff3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: xtheosirian <https://aur.archlinux.org/account/xtheosirian>
+
+pkgname=vim-ron-git
+pkgver=r4.2ec8a5d
+pkgrel=1
+pkgdesc="RON syntax highlighting for Vim."
+arch=('any')
+url='https://github.com/ron-rs/ron.vim'
+license=('unknown')
+depends=('vim')
+makedepends=('git')
+conflicts=('vim-ron')
+provides=('vim-ron')
+groups=('vim-plugins')
+source=("git+https://github.com/ron-rs/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p "${_installpath}"
+ cp -r ftdetect ftplugin indent syntax "${_installpath}"
+}