summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 10:32:38 +0200
committerChristian Hesse2015-06-30 10:32:38 +0200
commit1d61643ce23aa5c0d4789b994e04493c90fb2613 (patch)
treed2a43ba9bdc79aa8f27cc474a80f4e6085e24ee3
downloadaur-1d61643ce23aa5c0d4789b994e04493c90fb2613.tar.gz
initial import of vim-skeleton 0.0.3.r0.g7309644-8
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
-rw-r--r--skeleton-c19
-rw-r--r--skeleton-h17
-rw-r--r--skeleton-html32
-rw-r--r--skeleton-perl17
-rw-r--r--skeleton-sh14
-rw-r--r--vim-skeleton.install4
8 files changed, 172 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc67304e69e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vim-skeleton
+ pkgdesc = Vim plugin: Skeleton for newly created buffers
+ pkgver = 0.0.3.r0.g7309644
+ pkgrel = 8
+ url = https://github.com/kana/vim-skeleton
+ install = vim-skeleton.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vim
+ source = git://github.com/kana/vim-skeleton.git
+ source = skeleton-c
+ source = skeleton-h
+ source = skeleton-html
+ source = skeleton-perl
+ source = skeleton-sh
+ sha256sums = SKIP
+ sha256sums = 3e4c3ee99b954a71493117b02fb331c7f351fab51aaea9ed2c84787012538630
+ sha256sums = b629086dc2208711268f05b26508393e602c0111585ae6f8d1ed773a09f72cd6
+ sha256sums = 9af84b93ddf9a04a0c608cce0a8838f20e9c5c8ca7668b33e0b5ec44115d799a
+ sha256sums = 70bba951dc6fdca3e2f8354ebb157372a8cc0e84670168b411a62532929c9a04
+ sha256sums = 052ef4da82553141d8c65af51ffe082cd322f0dbad96b17c7240bbe5b1849ac3
+
+pkgname = vim-skeleton
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97c800436558
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=vim-skeleton
+pkgver=0.0.3.r0.g7309644
+pkgrel=8
+pkgdesc="Vim plugin: Skeleton for newly created buffers"
+arch=('any')
+url="https://github.com/kana/vim-skeleton"
+license=('GPL')
+depends=('vim')
+makedepends=('git')
+install=vim-skeleton.install
+source=('git://github.com/kana/vim-skeleton.git'
+ 'skeleton-c'
+ 'skeleton-h'
+ 'skeleton-html'
+ 'skeleton-perl'
+ 'skeleton-sh')
+sha256sums=('SKIP'
+ '3e4c3ee99b954a71493117b02fb331c7f351fab51aaea9ed2c84787012538630'
+ 'b629086dc2208711268f05b26508393e602c0111585ae6f8d1ed773a09f72cd6'
+ '9af84b93ddf9a04a0c608cce0a8838f20e9c5c8ca7668b33e0b5ec44115d799a'
+ '70bba951dc6fdca3e2f8354ebb157372a8cc0e84670168b411a62532929c9a04'
+ '052ef4da82553141d8c65af51ffe082cd322f0dbad96b17c7240bbe5b1849ac3')
+
+pkgver() {
+ cd vim-skeleton/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+package() {
+ install -D -m0644 ${srcdir}/vim-skeleton/plugin/skeleton.vim ${pkgdir}/usr/share/vim/vimfiles/plugin/skeleton.vim
+ install -D -m0644 ${srcdir}/vim-skeleton/doc/skeleton.txt ${pkgdir}/usr/share/doc/${pkgname}/skeleton.txt
+
+ for SKELETON in c h html perl sh; do
+ install -D -m0644 ${srcdir}/skeleton-${SKELETON} ${pkgdir}/usr/share/vim/vimfiles/xtr/skeleton/${SKELETON}
+ done
+}
+
diff --git a/skeleton-c b/skeleton-c
new file mode 100644
index 000000000000..f5d9b073a486
--- /dev/null
+++ b/skeleton-c
@@ -0,0 +1,19 @@
+/*
+ * (C) 2015 by Christian Hesse <mail@eworm.de>
+ *
+ * This software may be used and distributed according to the terms
+ * of the GNU General Public License, incorporated herein by reference.
+ *
+ * This is an example code skeleton provided by vim-skeleton.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+
+int main(int argc, char **argv) {
+ /* your code goes here */
+
+ return EXIT_SUCCESS;
+}
+
+// vim: set syntax=c:
diff --git a/skeleton-h b/skeleton-h
new file mode 100644
index 000000000000..686701eea6ec
--- /dev/null
+++ b/skeleton-h
@@ -0,0 +1,17 @@
+/*
+ * (C) 2015 by Christian Hesse <mail@eworm.de>
+ *
+ * This software may be used and distributed according to the terms
+ * of the GNU General Public License, incorporated herein by reference.
+ *
+ * This is an example code skeleton provided by vim-skeleton.
+ */
+
+#ifndef _SKELETON_H
+#define _SKELETON_H
+
+/* your code goes here */
+
+#endif /* _SKELETON_H */
+
+// vim: set syntax=c:
diff --git a/skeleton-html b/skeleton-html
new file mode 100644
index 000000000000..d89311919b47
--- /dev/null
+++ b/skeleton-html
@@ -0,0 +1,32 @@
+<!DOCTYPE HTML>
+<html lang="en">
+<head>
+<title>Title</title>
+
+<!-- (C) 2015 by Christian Hesse <mail@eworm.de>
+
+ This software may be used and distributed according to the terms
+ of the GNU General Public License, incorporated herein by reference.
+
+ This is an example code skeleton provided by vim-skeleton. //-->
+
+<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
+<meta name="description" content="Description">
+<meta name="author" content="Author">
+<meta name="keywords" content="Keywords">
+
+<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico">
+
+<style type="text/css">
+body { text-align: center; font-family: sans-serif; }
+h1 { text-align: center; }
+img { border: 0px; }
+p { text-indent: 10px; }
+</style>
+
+</head>
+
+<body>
+ <!-- Your markup here //-->
+</body>
+</html>
diff --git a/skeleton-perl b/skeleton-perl
new file mode 100644
index 000000000000..0b54e96942f7
--- /dev/null
+++ b/skeleton-perl
@@ -0,0 +1,17 @@
+#!/usr/bin/perl -w
+#
+# (C) 2015 by Christian Hesse <mail@eworm.de>
+#
+# This software may be used and distributed according to the terms
+# of the GNU General Public License, incorporated herein by reference.
+#
+# This is an example code skeleton provided by vim-skeleton.
+
+use strict;
+use warnings;
+
+# your code goes here
+
+exit 0;
+
+# vim: set syntax=perl:
diff --git a/skeleton-sh b/skeleton-sh
new file mode 100644
index 000000000000..4a894e972a91
--- /dev/null
+++ b/skeleton-sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# (C) 2015 by Christian Hesse <mail@eworm.de>
+#
+# This software may be used and distributed according to the terms
+# of the GNU General Public License, incorporated herein by reference.
+#
+# This is an example code skeleton provided by vim-skeleton.
+
+# your code goes here
+
+exit 0
+
+# vim: set syntax=sh:
diff --git a/vim-skeleton.install b/vim-skeleton.install
new file mode 100644
index 000000000000..a79e8f67336c
--- /dev/null
+++ b/vim-skeleton.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo " > Now place your skeleton file to /usr/share/vim/vimfiles/xtr/skeleton"
+ echo " > or ~/.vim/xtr/skeleton!"
+}