summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-26 13:05:54 -0600
committerLuis Martinez2021-11-26 13:06:07 -0600
commita7a3d65b1ae8196e007e8c77fefa7bdcfdf9ce01 (patch)
treebbe8e7868870bccd7cbb4378bdc1fb20f5977e3a
parentf6fb3a622b89e5c0743729436d6decb2b8170d68 (diff)
downloadaur-vim-sneak-git.tar.gz
package rewrite
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cf495ee69a3..63d873bd8e23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = vim-sneak-git
- pkgdesc = VIM plugin for jumping to a location specified by two characters
- pkgver = r293.5cd2642
+ pkgdesc = Motion plugin for Vim
+ pkgver = 1.9.r6.g94c2de4
pkgrel = 1
- url = http://www.vim.org/scripts/script.php?script_id=4809
+ url = https://github.com/justinmk/vim-sneak
arch = any
+ groups = vim-plugins
license = MIT
makedepends = git
- depends = vim
- source = git+https://github.com/justinmk/vim-sneak
- md5sums = SKIP
+ depends = vim-plugin-runtime
+ provides = vim-sneak
+ conflicts = vim-sneak
+ source = vim-sneak-git::git+https://github.com/justinmk/vim-sneak
+ sha256sums = SKIP
pkgname = vim-sneak-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 23eaef7e409c..3e3a0f428f9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,34 @@
-_name="sneak"
-_reponame="vim-${_name}"
-pkgname="${_reponame}-git"
-pkgver=r293.5cd2642
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+
+pkgname=vim-sneak-git
+pkgver=1.9.r6.g94c2de4
pkgrel=1
-pkgdesc="VIM plugin for jumping to a location specified by two characters"
+pkgdesc='Motion plugin for Vim'
arch=('any')
-url="http://www.vim.org/scripts/script.php?script_id=4809"
+url='https://github.com/justinmk/vim-sneak'
license=('MIT')
-depends=('vim')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
makedepends=('git')
-source=("git+https://github.com/justinmk/${_reponame}")
-md5sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+PURGE_TARGETS=('.gitignore')
pkgver() {
- cd "${srcdir}/${_reponame}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git -C "$pkgname" describe --long --tags | sed 's/-/.r/;s/-/./'
}
package() {
- cd "${srcdir}/${_reponame}/plugin"
- install -Dm 644 ${_name}.vim "${pkgdir}/usr/share/vim/vim74/plugin/${_name}.vim"
+ cd "$pkgname"
+ find autoload doc plugin \
+ -type f \
+ -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
+
+# vim:set et sw=2 ts=2 tw=79: