summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-05 16:02:19 -0500
committerLuis Martinez2021-11-05 16:02:19 -0500
commitcdbfcdc56448ed90a0f23675bfb24ebe930e231a (patch)
tree76a192dab648beccd0269bd0dd3e629877759278
downloadaur-cdbfcdc56448ed90a0f23675bfb24ebe930e231a.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93b933720134
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-speeddating-git
+ pkgdesc = Proper date incrementing for Vim
+ pkgver = 20151024.r6.g95da3d7
+ pkgrel = 1
+ url = https://github.com/tpope/vim-speeddating
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-speeddating
+ conflicts = vim-speeddating
+ source = vim-speeddating-git::git+https://github.com/tpope/vim-speeddating
+ md5sums = SKIP
+
+pkgname = vim-speeddating-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c3c2cac8383
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=vim-speeddating-git
+pkgver=20151024.r6.g95da3d7
+pkgrel=1
+pkgdesc="Proper date incrementing for Vim"
+arch=('any')
+url="https://github.com/tpope/vim-speeddating"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 README.markdown -t "$pkgdir/usr/share/doc/$pkgname/"
+}