summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-06-09 08:47:18 +1000
committerRhinoceros2015-06-09 08:47:18 +1000
commit07bde278fcfe50904cf29cc7a3db7a6eb0a13f7c (patch)
tree2702d8d235d5adeb1cf4877a71bfd501586ac373
downloadaur-07bde278fcfe50904cf29cc7a3db7a6eb0a13f7c.tar.gz
Initial commit of git version
* vim-startify is no longer offered as a versioned release. Sourcing from git is the only way to get it. * This package is based on vim-startify * Correct url, licence, depends, use install, add vimdoc.install, other minor cleanups
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--vimdoc.install16
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7763a3af6e6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-startify-git
+ pkgdesc = A fancy start screen for Vim.
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://github.com/mhinz/vim-startify
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-startify
+ conflicts = vim-startify
+ source = git+https://github.com/mhinz/vim-startify.git
+ sha256sums = SKIP
+
+pkgname = vim-startify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ed801d030bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Mizuchi <ytj000+AUR@gmail.com>
+
+pkgname=vim-startify-git
+pkgver=1.8
+pkgrel=1
+pkgdesc='A fancy start screen for Vim.'
+arch=('any')
+url='https://github.com/mhinz/vim-startify'
+license=('MIT')
+depends=('vim')
+makedepends=('git')
+conflicts=('vim-startify')
+provides=('vim-startify')
+groups=('vim-plugins')
+install='vimdoc.install'
+source=("git+https://github.com/mhinz/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+package() {
+ cd ${pkgname%-git}
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d "${_installpath}/"{autoload,doc,plugin,syntax}
+ install -m644 autoload/startify.vim "${_installpath}/autoload/"
+ install -m644 doc/startify.txt "${_installpath}/doc/"
+ install -m644 plugin/startify.vim "${_installpath}/plugin/"
+ install -m644 syntax/startify.vim "${_installpath}/syntax/"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..1f6a30927ea2
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: