summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2021-12-14 23:45:16 -0700
committerBrian Bidulock2021-12-14 23:45:16 -0700
commitb0c6a19c0a6c41458fdd6aef249a8fc3db235f1c (patch)
tree5f462976cfa70032e0d15cb82cf41b7548229f0a
parented5a50b9620c3642d4c8dbe1d2300543b5ce823e (diff)
downloadaur-b0c6a19c0a6c41458fdd6aef249a8fc3db235f1c.tar.gz
uppkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e1f58ea2bda..8aeabc920115 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = vim-systemd
pkgdesc = ViM syntax highlighting for systemd unit files
- pkgver = 20170410
+ pkgver = r34.7c4724d
pkgrel = 1
- url = http://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git/
+ url = https://github.com/wgwoods/vim-scripts
arch = any
- license = unknown
+ license = GPL
+ makedepends = git
depends = vim
- source = git+https://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git
+ source = git+https://github.com/wgwoods/vim-scripts.git
md5sums = SKIP
pkgname = vim-systemd
-
diff --git a/PKGBUILD b/PKGBUILD
index f5666790f07f..d9d2c585b2ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
+_pkgname=vim-scripts
pkgname=vim-systemd
-pkgver=20170410
+pkgver=r34.7c4724d
pkgrel=1
pkgdesc="ViM syntax highlighting for systemd unit files"
arch=("any")
-url="http://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git/"
-license=('unknown')
+#url="http://fedorapeople.org/cgit/wwoods/public_git/${_pkgname}.git/"
+url=https://github.com/wgwoods/${_pkgname}
+license=('GPL')
depends=('vim')
-source=("git+https://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git")
+makedepends=('git')
+#source=("git+https://fedorapeople.org/cgit/wwoods/public_git/${_pkgname}.git")
+source=("git+https://github.com/wgwoods/${_pkgname}.git")
md5sums=('SKIP')
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package () {
- cd vim-scripts
+ cd ${_pkgname}
install -Dm0644 ftdetect/systemd.vim "$pkgdir"/usr/share/vim/vimfiles/ftdetect/systemd.vim
install -Dm0644 ftdetect/udev.vim "$pkgdir"/usr/share/vim/vimfiles/ftdetect/udev.vim
install -Dm0644 syntax/systemd.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/systemd.vim