summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2020-07-14 01:30:22 +0200
committerSven-Hendrik Haase2020-07-14 01:30:22 +0200
commit15cf61df9651562af26ec2f1134bc28cadb4ba43 (patch)
treed0bda7325de52e242725c0ad0cfaf3865f5c7320
downloadaur-15cf61df9651562af26ec2f1134bc28cadb4ba43.tar.gz
Moved from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rw-r--r--download_script.php?src_id=19574bin0 -> 51455 bytes
-rw-r--r--license.txt8
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0d4e4c630e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-taglist
+ pkgdesc = A source code browser plugin for vim
+ pkgver = 46
+ pkgrel = 5
+ url = http://vim-taglist.sourceforge.net/
+ arch = any
+ groups = vim-plugins
+ license = custom
+ makedepends = unzip
+ depends = vim
+ depends = ctags
+ source = https://www.vim.org/scripts/download_script.php?src_id=19574
+ source = license.txt
+ md5sums = 96e2ba879964b3c9e790e3906934d0c0
+ md5sums = efbd5986e691ce8c876fb86e8f5961ea
+
+pkgname = vim-taglist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eab6fba7065b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=vim-taglist
+pkgver=46
+_scriptid=19574
+pkgrel=5
+pkgdesc="A source code browser plugin for vim"
+arch=('any')
+url="http://vim-taglist.sourceforge.net/"
+license=('custom')
+depends=('vim' 'ctags')
+makedepends=('unzip')
+groups=('vim-plugins')
+source=(https://www.vim.org/scripts/download_script.php?src_id=$_scriptid
+ license.txt)
+md5sums=('96e2ba879964b3c9e790e3906934d0c0'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+build() {
+ cd ${srcdir}
+
+ mv download_script.php?src_id=$_scriptid taglist_${pkgver}.zip
+ unzip -qqo taglist_${pkgver}.zip
+}
+
+package() {
+ cd ${srcdir}
+
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -Dm644 doc/taglist.txt $installpath/doc/taglist.txt
+ install -Dm644 plugin/taglist.vim $installpath/plugin/taglist.vim
+ install -Dm644 ${srcdir}/license.txt \
+ ${pkgdir}/usr/share/licenses/vim-taglist/license.txt
+}
diff --git a/download_script.php?src_id=19574 b/download_script.php?src_id=19574
new file mode 100644
index 000000000000..91024bad9dda
--- /dev/null
+++ b/download_script.php?src_id=19574
Binary files differ
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.