summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2020-05-04 08:59:49 +0100
committerWill Handley2020-05-04 08:59:49 +0100
commit1bae2dbd8f96e5d9dd7c7cf9318b706f0ee3209b (patch)
treea95b43068c8c9a355b6497907ccddb729db2091b
downloadaur-1bae2dbd8f96e5d9dd7c7cf9318b706f0ee3209b.tar.gz
Version 1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bf4932d73b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-taskwarrior
+ pkgdesc = vim interface for taskwarrior
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/blindFS/vim-taskwarrior
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ depends = vim
+ options = !emptydirs
+ source = https://github.com/blindFS/vim-taskwarrior/archive/v1.0.tar.gz
+ sha256sums = 80a772dad0a31c628143fe4f2421b00fba8b3f09a2c3611ac4dad6e272e6bd1e
+
+pkgname = vim-taskwarrior
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b35672b131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=vim-taskwarrior
+pkgver=1.0
+pkgrel=1
+pkgdesc="vim interface for taskwarrior"
+arch=(any)
+url="https://github.com/blindFS/${pkgname}"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('80a772dad0a31c628143fe4f2421b00fba8b3f09a2c3611ac4dad6e272e6bd1e')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ find autoload doc ftplugin plugin syntax -type d -exec install -d ${installpath}/{} \;
+ find autoload doc ftplugin plugin syntax -type f -exec install -Dm644 {} ${installpath}/{} \;
+}