summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-02-23 12:29:14 +0530
committerAnkit R Gadiya2018-02-23 12:29:14 +0530
commitb2b5151fb44ccfc14ffbfb331ba301b97490b1cb (patch)
tree60770c14dcbd4b9397fc8d1da015d6686d0fc6af
parent4686dc4075d3ab830fe46f07176d6e5a82c24f14 (diff)
downloadaur-vim-tcomment.tar.gz
Update: Renamed the package, removed License install part, and other small changes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b8117a287ce..9adcbe216925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
-pkgbase = tcomment-vim
+pkgbase = vim-tcomment
pkgdesc = An extensible & universal comment vim-plugin that also handles embedded filetypes
pkgver = 3.08.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tomtom/tcomment_vim
arch = any
groups = vim-plugins
license = GPL3
depends = vim
- source = tcomment-vim-3.08.1.tar.gz::https://github.com/tomtom/tcomment_vim/archive/3.08.1.tar.gz
+ source = vim-tcomment-3.08.1.tar.gz::https://github.com/tomtom/tcomment_vim/archive/3.08.1.tar.gz
md5sums = 6ea8f4ce78411efba444a0218e111219
-pkgname = tcomment-vim
+pkgname = vim-tcomment
diff --git a/PKGBUILD b/PKGBUILD
index 3e94cbc28020..c9cb4d0e8feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
# Maintainer: Ankit R Gadiya <arch@argp.in>
-pkgname=tcomment-vim
+pkgname=vim-tcomment
pkgver=3.08.1
-pkgrel=2
-pkgdesc="An extensible & universal comment vim-plugin that also
-handles embedded filetypes"
+pkgrel=3
+pkgdesc="An extensible & universal comment vim-plugin that also handles embedded filetypes"
license=('GPL3')
arch=('any')
url="https://github.com/tomtom/tcomment_vim"
depends=('vim')
groups=('vim-plugins')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tomtom/${pkgname/-/_}/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tomtom/tcomment_vim/archive/${pkgver}.tar.gz")
md5sums=('6ea8f4ce78411efba444a0218e111219')
package() {
- install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/plugin/tcomment.vim" \
+ install -Dm755 "tcomment_vim-${pkgver}/plugin/tcomment.vim" \
"${pkgdir}/usr/share/vim/vimfiles/plugin/tcomment.vim"
- install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/doc/tcomment.txt" \
+ install -Dm755 "tcomment_vim-${pkgver}/doc/tcomment.txt" \
"${pkgdir}/usr/share/vim/vimfiles/doc/tcomment.txt"
- install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/autoload/tcomment.vim" \
+ install -Dm755 "tcomment_vim-${pkgver}/autoload/tcomment.vim" \
"${pkgdir}/usr/share/vim/vimfiles/autoload/tcomment.vim"
-
- install -Dm644 "${srcdir}/${pkgname/-/_}-${pkgver}/LICENSE.TXT" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}