summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-02-22 16:46:39 +0530
committerAnkit R Gadiya2018-02-22 16:46:39 +0530
commitce8719354b9853990e64f81881b6ec703490c3bb (patch)
treef3487a8a582588029927ee04dcb75ce51a71e534
downloadaur-ce8719354b9853990e64f81881b6ec703490c3bb.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c92b839ed0ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tcomment-vim
+ pkgdesc = An extensible & universal comment vim-plugin that also handles embedded filetypes
+ pkgver = 3.08.1
+ pkgrel = 1
+ url = https://github.com/tomtom/tcomment_vim
+ arch = any
+ groups = vim-plugins
+ license = GPL3
+ depends = vim
+ source = https://github.com/tomtom/tcomment_vim/archive/3.08.1.tar.gz
+ md5sums = 6ea8f4ce78411efba444a0218e111219
+
+pkgname = tcomment-vim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306c2603f6ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+
+pkgname=tcomment-vim
+pkgver=3.08.1
+pkgrel=1
+pkgdesc="An extensible & universal comment vim-plugin that also
+handles embedded filetypes"
+license=('GPL3')
+arch=('any')
+url="https://github.com/tomtom/tcomment_vim"
+depends=('vim')
+groups=('vim-plugins')
+source=("https://github.com/tomtom/${pkgname/-/_}/archive/${pkgver}.tar.gz")
+md5sums=('6ea8f4ce78411efba444a0218e111219')
+
+package() {
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles/"{doc,plugin,autoload}
+
+ install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/plugin/tcomment.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/plugin/tcomment.vim"
+ install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/doc/tcomment.txt" \
+ "${pkgdir}/usr/share/vim/vimfiles/doc/tcomment.txt"
+ install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/autoload/tcomment.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/autoload/tcomment.vim"
+}