summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-04-07 23:43:01 +0530
committerAnkit R Gadiya2018-04-07 23:43:01 +0530
commitababc17a88c4b9a47728951b379bea637cb13930 (patch)
tree30060e77c98a9fbedc82da2d796dd77bab948ae6
downloadaur-ababc17a88c4b9a47728951b379bea637cb13930.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ded0ab0e957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-tcomment-git
+ pkgdesc = An extensible & universal comment vim-plugin that also handles embedded filetypes (Git Version)
+ pkgver = 3.08.1.r28.ge365bfa
+ pkgrel = 1
+ url = https://github.com/tomtom/tcomment_vim
+ arch = any
+ groups = vim-plugins
+ license = GPL3
+ makedepends = git
+ depends = vim
+ source = git+https://github.com/tomtom/tcomment_vim/
+ md5sums = SKIP
+
+pkgname = vim-tcomment-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7452a9411f74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+
+pkgname=vim-tcomment-git
+pkgver=3.08.1.r28.ge365bfa
+pkgrel=1
+pkgdesc="An extensible & universal comment vim-plugin that also handles embedded filetypes (Git Version)"
+license=('GPL3')
+arch=('any')
+url="https://github.com/tomtom/tcomment_vim"
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+source=("git+https://github.com/tomtom/tcomment_vim/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd tcomment_vim
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm755 "tcomment_vim/plugin/tcomment.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/plugin/tcomment.vim"
+ install -Dm755 "tcomment_vim/doc/tcomment.txt" \
+ "${pkgdir}/usr/share/vim/vimfiles/doc/tcomment.txt"
+ install -Dm755 "tcomment_vim/autoload/tcomment.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/autoload/tcomment.vim"
+}