summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-07-06 09:21:39 +0200
committeraksr2015-07-06 09:21:39 +0200
commit428d8f4109ae90511ae26a11708e58f1d6ac3d6e (patch)
tree8aacf8198b4402840b238a3b79094a542a89a122
downloadaur-428d8f4109ae90511ae26a11708e58f1d6ac3d6e.tar.gz
Start.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
-rw-r--r--vimdoc.install15
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0730f63a5b06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-tex_nine
+ pkgdesc = A semi-automatic LaTeX ftplugin with lots of firepower.
+ pkgver = 1.3.13
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=3508
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = GPL
+ depends = python2
+ depends = vim
+ optdepends = texlive-bin: compile TeX files
+ source = vim-tex_nine.tar.gz::http://www.vim.org/scripts/download_script.php?src_id=22415
+ md5sums = 3a44ec79b2bb8da015035dc9efc1c2c4
+ sha1sums = 480b76fe9db6081f396f25a7238ac2405d0c1727
+ sha256sums = 3447255bb878d66cc4d87b6fe0f7f604f1e6f0f4b32bb2e33faa10aaa81f5ab3
+
+pkgname = vim-tex_nine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f05730cf1a63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Sara <sara at archlinux dot us>
+# Maintainer: aksr <aksr at t-com dot me>
+_pkgname=tex_nine
+pkgname=vim-${_pkgname}
+pkgver=1.3.13
+_scriptid=22415
+pkgrel=1
+pkgdesc="A semi-automatic LaTeX ftplugin with lots of firepower."
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=3508"
+license=('GPL')
+depends=('python2' 'vim')
+optdepends=('texlive-bin: compile TeX files')
+groups=('vim-plugins')
+install=vimdoc.install
+source=(${pkgname}.tar.gz::"http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
+md5sums=('3a44ec79b2bb8da015035dc9efc1c2c4')
+sha1sums=('480b76fe9db6081f396f25a7238ac2405d0c1727')
+sha256sums=('3447255bb878d66cc4d87b6fe0f7f604f1e6f0f4b32bb2e33faa10aaa81f5ab3')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/ftplugin/${_pkgname}"
+ sed -e 's|#!/usr/bin/python|#!/usr/bin/python2|' -i evince_dbus.py
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/ftplugin/${_pkgname}"
+
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d $installpath/{autoload,doc,ftplugin,indent}
+ install -d $installpath/ftplugin/${_pkgname}/{skeleton,snippets}
+ install -Dm644 *.vim *.py *.txt $installpath/ftplugin/${_pkgname}/
+
+ for i in skeleton snippets
+ do
+ install -Dm644 "${i}"/* $installpath/ftplugin/${_pkgname}/"${i}"/
+ done
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -Dm644 ftplugin/*.vim $installpath/ftplugin/
+
+ for i in autoload doc indent
+ do
+ install -Dm644 "${i}"/* $installpath/"${i}"/
+ done
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..62fe5271415d
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating vim help tags... "
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+