summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-18 21:17:37 -0500
committerLuis Martinez2021-06-18 21:17:37 -0500
commit53a09747a9cf32facb92a630de57d971dddc9400 (patch)
tree85d651ec2356ef7e23a7bcd950fd0bcd07a93855
downloadaur-vim-toast-git.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c80d55e941b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-toast-git
+ pkgdesc = A colorful, medium-contrast colorscheme based on Tomorrow
+ pkgver = r22.6ef5cea
+ pkgrel = 1
+ url = https://github.com/jsit/toast.vim
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = git
+ depends = vim-plugin-runtime
+ provides = vim-toast
+ conflicts = vim-toast
+ source = vim-toast-git::git+https://github.com/jsit/toast.vim
+ sha256sums = SKIP
+
+pkgname = vim-toast-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd0a2e10b86a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-toast-git
+pkgver=r22.6ef5cea
+pkgrel=1
+pkgdesc="A colorful, medium-contrast colorscheme based on Tomorrow"
+arch=('any')
+url="https://github.com/jsit/toast.vim"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dvm 644 colors/toast.vim -t "$pkgdir/usr/share/vim/vimfiles/colors/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}