summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Rebischke2017-02-08 01:31:48 +0100
committerChristian Rebischke2017-02-08 01:31:48 +0100
commitf37768378eba68e65d879f8262309004143d47c6 (patch)
treef2e85aaafe41fca033be25a36c3c45818aece8cc
downloadaur-f37768378eba68e65d879f8262309004143d47c6.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d8f226cc569
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-unimpaired
+ pkgdesc = pairs of handy bracket mappings
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/tpope/vim-unimpaired
+ arch = any
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = vim-unimpaired-1.2.tar.gz::https://github.com/tpope/vim-unimpaired/archive/v1.2.tar.gz
+ sha512sums = 842eeffa05f9dc753f31b8af393e5c38e5d59515384929095ec61a6223aa55c01c203bf6ed92c41c6c099cb82392ee2402404d1ebc2d5213963f94c9443dfce8
+
+pkgname = vim-unimpaired
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dba3e160478b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+
+pkgname=vim-unimpaired
+pkgver=1.2
+pkgrel=1
+pkgdesc='pairs of handy bracket mappings'
+arch=('any')
+url='https://github.com/tpope/vim-unimpaired'
+license=('custom')
+depends=('vim')
+groups=('vim-plugins')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tpope/vim-unimpaired/archive/v${pkgver}.tar.gz")
+sha512sums=('842eeffa05f9dc753f31b8af393e5c38e5d59515384929095ec61a6223aa55c01c203bf6ed92c41c6c099cb82392ee2402404d1ebc2d5213963f94c9443dfce8')
+
+package() {
+ cd "${srcdir}/vim-unimpaired-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles/"{plugin,doc}
+ install -D -m644 plugin/unimpaired.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/"
+ install -D -m644 doc/unimpaired.txt "${pkgdir}/usr/share/vim/vimfiles/doc/"
+}
+
+# vim:set et sw=2 ts=2 tw=79: