summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-04-16 17:28:35 -0500
committerlmartinez-mirror2021-04-16 17:28:35 -0500
commit7bca1d58396ff003003510169045d8f38faedf06 (patch)
tree60ea88f17695ec14133860792a54723a0f1df7cf
downloadaur-vim-vifm-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9c44093f952
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-vifm-git
+ pkgdesc = Vim plugin that allows use of vifm as a file picker
+ pkgver = 0.11.r72.g1fec4a02
+ pkgrel = 1
+ url = https://github.com/vifm/vifm.vim
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ makedepends = git
+ depends = vim-plugin-runtime
+ depends = vifm
+ provides = vim-vifm
+ conflicts = vim-vifm
+ source = vim-vifm-git::git+https://github.com/vifm/vifm.vim
+ md5sums = SKIP
+
+pkgname = vim-vifm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0487c47255f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: lmartinez-mirror
+pkgname=vim-vifm-git
+pkgver=0.11.r72.g1fec4a02
+pkgrel=1
+pkgdesc="Vim plugin that allows use of vifm as a file picker"
+arch=('any')
+url="https://github.com/vifm/vifm.vim"
+license=('unknown')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime' 'vifm')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc ftdetect ftplugin plugin syntax \
+ -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+}