summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2020-01-02 22:25:02 +1100
committerRhinoceros2020-01-02 22:25:02 +1100
commit57bcea54f625b1f3ff52a876e2cfde6c2c010470 (patch)
treefdaae94681854fc6e101f6bd5ba987685fc4cce3
parent00dc5c6364e62e6836f129c177ff2d5cef639b54 (diff)
downloadaur-57bcea54f625b1f3ff52a876e2cfde6c2c010470.tar.gz
Update to 2.4.1-2
* Remove unused python2 dependency * Source licence directly, now from explicit file upstream * Remove old, old licence (not used in previous version; from older PKGBUILD)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 4 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 701876fbe44c..0ad1ee51e1c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = vim-vimwiki
pkgdesc = A personal wiki for Vim
pkgver = 2.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vimwiki/vimwiki
arch = any
groups = vim-plugins
license = MIT
depends = vim
- depends = python2
source = https://github.com/vimwiki/vimwiki/archive/v2.4.1.tar.gz
sha256sums = ccae0b8865bd3aea5f0834e888af294c654238f1d472390c1606f0588f01213a
diff --git a/PKGBUILD b/PKGBUILD
index e618e7cea82f..8c61a77ce773 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,16 @@
pkgname=vim-vimwiki
pkgver=2.4.1
-pkgrel=1
+pkgrel=2
pkgdesc='A personal wiki for Vim'
arch=('any')
url='https://github.com/vimwiki/vimwiki'
license=('MIT')
groups=('vim-plugins')
-depends=('vim' 'python2')
+depends=('vim')
source=("https://github.com/vimwiki/vimwiki/archive/v${pkgver}.tar.gz")
sha256sums=('ccae0b8865bd3aea5f0834e888af294c654238f1d472390c1606f0588f01213a')
-prepare() {
- # Extract licence from vim's help
- grep '^[0-9]*. License' "${pkgname#vim-}-${pkgver}/doc/vimwiki.txt" -A 1000 > LICENCE
-}
-
package () {
cd "${pkgname#vim-}-${pkgver}"
@@ -30,5 +25,5 @@ package () {
for x in {ftplugin,plugin,syntax}; do
install -Dm644 $x/* $pkgdir/usr/share/vim/vimfiles/$x/
done
- install -Dm644 ../LICENCE $pkgdir/usr/share/licenses/$pkgname/LICENCE
+ install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$pkgname/LICENCE
}