summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2016-03-30 13:41:43 +1100
committerRhinoceros2016-03-30 13:41:43 +1100
commitee5992d0f158641e4ceab9030b762057dbaed8b5 (patch)
treeef9c9ad865a301f4718c3e79b26772756405840c
parentd81ddbbf15c734688250616b842f06e79d2e0fa7 (diff)
downloadaur-ee5992d0f158641e4ceab9030b762057dbaed8b5.tar.gz
Updated to 2.2.1-1
* Removed convert_links scripts (previous vimwiki was from four years ago) and .gitignore * Update pkgdesc, url and source * Correct licence, and extract from vim's help * Use sha256sums * Minor style cleanups
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD43
-rw-r--r--convert-links.patchbin3607 -> 0 bytes
-rw-r--r--convert_links.py66
-rw-r--r--vimdoc.install16
-rw-r--r--vimwiki.install24
7 files changed, 38 insertions, 140 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaf3166749f6..a3c4ea1ab099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Mar 30 02:40:51 UTC 2016
pkgbase = vim-vimwiki
- pkgdesc = Personal Wiki for Vim
- pkgver = 2.1
+ pkgdesc = A personal wiki for Vim
+ pkgver = 2.2.1
pkgrel = 1
- url = http://code.google.com/p/vimwiki/
- install = vimwiki.install
+ url = https://github.com/vimwiki/vimwiki
+ install = vimdoc.install
arch = any
groups = vim-plugins
license = MIT
- license = GPL3
depends = vim
depends = python2
- source = http://vimwiki.googlecode.com/files/vimwiki-2-1.zip
- source = license.txt
- source = convert_links.py
- source = convert-links.patch
- md5sums = 775877e910d5588f764472dd934a7000
- md5sums = e19fa0689d06a724fc8ddfe824ef2680
- md5sums = 0fc0e816bb93e408b62f74e8b2073daa
- md5sums = 1ba74a69c30927e947f22870c2551f73
+ source = https://github.com/vimwiki/vimwiki/archive/v2.2.1.tar.gz
+ sha256sums = be7bbb57482d05b5ee300a944dc3fce01c9c266d1b7509c079e3f667ad924c32
pkgname = vim-vimwiki
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index bd9b4a41adc0..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,8 +0,0 @@
-*.tar.gz
-*.tar.xz
-*.tgz
-*.rpm
-*.zip
-*.bz2
-src/
-pkg/
diff --git a/PKGBUILD b/PKGBUILD
index ce8b25e84d39..55eb9c47fc34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,35 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
# Contributor: Johannes Dewender < arch at JonnyJD dot net >
pkgname=vim-vimwiki
-pkgver=2.1
+pkgver=2.2.1
pkgrel=1
-pkgdesc="Personal Wiki for Vim"
+pkgdesc='A personal wiki for Vim'
arch=('any')
-url="http://code.google.com/p/vimwiki/"
-license=('MIT' 'GPL3')
+url='https://github.com/vimwiki/vimwiki'
+license=('MIT')
groups=('vim-plugins')
depends=('vim' 'python2')
-install=vimwiki.install
-source=(http://vimwiki.googlecode.com/files/vimwiki-2-1.zip
- license.txt
- convert_links.py
- convert-links.patch)
-md5sums=('775877e910d5588f764472dd934a7000'
- 'e19fa0689d06a724fc8ddfe824ef2680'
- '0fc0e816bb93e408b62f74e8b2073daa'
- '1ba74a69c30927e947f22870c2551f73')
+install=vimdoc.install
+source=("https://github.com/vimwiki/vimwiki/archive/v${pkgver}.tar.gz")
+sha256sums=('be7bbb57482d05b5ee300a944dc3fce01c9c266d1b7509c079e3f667ad924c32')
-build () {
- cd "$srcdir"
-
- # change symlink to file
- mv convert_links.py convert_links.symlink
- cp -L convert_links.symlink convert_links.py
- rm convert_links.symlink
- patch -p1 < convert-links.patch
+prepare() {
+ # Extract licence from vim's help
+ grep '^[0-9]*. License' "${pkgname#vim-}-${pkgver}/doc/vimwiki.txt" -A 1000 > LICENCE
}
package () {
- cd "$srcdir"
+ cd "${pkgname#vim-}-${pkgver}"
install -d $pkgdir/usr/share/vim/vimfiles/autoload/vimwiki
install -Dm644 autoload/vimwiki/* \
${pkgdir}/usr/share/vim/vimfiles/autoload/vimwiki/
install -d $pkgdir/usr/share/vim/vimfiles/{doc,ftplugin,plugin,syntax}
+ install -Dm644 doc/vimwiki.txt $pkgdir/usr/share/vim/vimfiles/doc/
for x in {ftplugin,plugin,syntax}; do
install -Dm644 $x/* $pkgdir/usr/share/vim/vimfiles/$x/
done
- install -Dm644 license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
- install -Dm644 doc/vimwiki.txt $pkgdir/usr/share/vim/vimfiles/doc/
-
- # install convert-links
- install -D convert_links.py $pkgdir/usr/bin/vimwiki_convert_links
+ install -Dm644 ../LICENCE $pkgdir/usr/share/licenses/$pkgname/LICENCE
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/convert-links.patch b/convert-links.patch
deleted file mode 100644
index 3e3bac381373..000000000000
--- a/convert-links.patch
+++ /dev/null
Binary files differ
diff --git a/convert_links.py b/convert_links.py
deleted file mode 100644
index be4a4e08ef41..000000000000
--- a/convert_links.py
+++ /dev/null
@@ -1,66 +0,0 @@
-''' Convert CamelCase links in a vimwiki to enclosing with double square
-bracket format. Errs on the safe side by only converting CamelCase words that
-have a corresponding file.
-
-Be very careful running this script. Make a backup of your wiki before running
-it. Run this on a copy of your wiki and then check you are happy with the
-conversions. Carefully check the files and links that will be converted.
-
-Usage:
- python convert_links.py wiki_directory
-
-Bugs:
-* TODO CamelCase links already wrapped in [[ will have additional [[ added
-* All instances of filenames will be converted in some cases this might be incorrect
-
-License: GPL3
-Author: Julian Ryde
-
-'''
-
-import sys
-import os
-
-def is_camelcase(s):
- # works quite well but Camelcase returns true
- return (s != s.lower()) and (s != s.upper())
-
-
-wiki_ext = '.wiki'
-basedir = sys.argv[1] # base directory of the wiki
-#outputdir = sys.argv[2]
-
-# generate dictionary of file names
-
-wiki_files = os.listdir(basedir)
-
-# select .wiki files
-wiki_files = [wiki_file[:-5] for wiki_file in wiki_files if wiki_file.endswith(wiki_ext)]
-wiki_files.sort()
-# remove ones that are not CamelCase better to be safe and change minimally
-wiki_links = [wiki_file for wiki_file in wiki_files if is_camelcase(wiki_file)]
-
-print '\nWiki files to be altered in', basedir
-print wiki_files
-
-print '\nLinks to be converted within these files'
-print wiki_links
-
-res = raw_input("\nIf you are happy with these changes press enter to continue.")
-
-
-# turn into set for fast membership query
-wiki_links = set(wiki_links)
-
-
-# for each wiki file find all instances of members of wiki_files in the file
-# contents and replace
-for wiki_file in wiki_files:
- fname = os.path.join(basedir, wiki_file + wiki_ext)
- contents = open(fname).read()
- # replace each wiki_link with the new form for this file
- for wiki_link in wiki_links:
- contents = contents.replace(wiki_link, '[[' + wiki_link + ']]')
- # save modified contents
- #print 'Saving', fname
- open(fname, 'w').write(contents)
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..1f6a30927ea2
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n 'Updating vim help tags...'
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo 'done.'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vimwiki.install b/vimwiki.install
deleted file mode 100644
index 6796134f8094..000000000000
--- a/vimwiki.install
+++ /dev/null
@@ -1,24 +0,0 @@
-post_install() {
- echo -n "Updating vim help tags..."
- /usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
- echo "done."
-
- echo "The link syntax change with vimwiki 2."
- echo "CamelCase words are no longer considered links."
- echo "If you want to make all of these links, please use"
- echo " vimwiki_convert_links [wiki_directory]"
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install
-}
-
-op=$1
-shift
-
-$op $*